Limit switches not read

I am setting up a new machine Shapeoko 3 xxl

During the initialize machine sequence, I get an error that the machine is not able to find the limit switches.

Not sure what to try next…

Tim

First and foremost, contact support@carbide3d.com
While you wait for their answer, we can try and troubleshoot.
For initialization to work, you need all three limit switches to work (of course), and you can check if they do work by doing the following:

  • launch Carbide Motion
  • power up the machine
  • “Connect to cutter”, but don’t Initialize.
  • go the Settings menu, in the Machine tab
  • You should see a “GRBL Active input pins” line
  • then to test each switch: bring a spanner near the face of the switch (that has a “target” on it):
    • does the LED light up ?
    • does the corresponding blue LED on the controller light up?
    • do you see “X” or “Y” or “Z” in Carbide Motion’s “GRBL Active input Pins” line ?

Do this for each limit switch and you should be able to tell which one does not work, and then you can hopefully troubleshoot from there

2 Likes

My GRBL active input Pins says “no active pins”

Is that the case for each of the X, Y and Z limit switches, when you bring a spanner or other metal object to the front of the switch ? What about the LED on the switch and blue LED on the controller board ?

There is a red and yellow light both blinking. A solid blue light. The spanned seems to have no effect.

Sorry, my instructions above were misleading: bring the spanner (or a ruler) against the face that does not have the carbide3D logo on it" (for the Z switch that would be “under” the switch (bottom face)

I can get the X to react. The Y is constantly listed as active. I haven’t found the Z yet. Or it is not reacting.

X and Y seem to be reacting now. Still no Z - I havent found it yet

If the homing failed initially, it’s possible/likely that the gantry is stuck at the top of the Z axis travel, fully pushed against the Z limit switch. With the machine turned off you should be able to turn the leadscrew manually to move down the Z plate slightly. That said, if the plate is up against the limit switch, it should be active.

ok I found all 3. All 3 are reacting to the wrench and showing as active on the machine screen

Allright, so machine initialization should work now ?

I get the error - homing failed - couldn’t find limit switch. the router went up and down, over to the corner, vibrated slightly, then gave the above error message.

From your description it seems like Z axis is properly detected (the axis comes near the switch and then pull-off by a few mm, that’s normal), but that either the X or Y switch is not registering. One way to tell is to power off the machine, move it manually (very slowly) so that the gantry is close to the right end of the X rail, but in the middle of the Y rails: when you power on/initialize the machine you should then be able to tell if the grinding sound occurs when the X axis reaches its limit, or if it’s when the Y axis reaches the rear of the machine

If you haven’t contacted support@carbide3d.com, you should do so so they will follow up with you. There might be an intermittent signal issue due to wiring/connectors. Try and check if all wires are properly seated in their connectors

1 Like

Found it! I had a limit switch mounted backwards… Thanks for your help!

1 Like

Have not heard the word “spanner” since I left England :grin:

How about a shifting spanner? AKA cresent wrench

There are some great tutorials at my.carbide3d.com. Specifically, lesson 4 in Running a Shapeoko called “Checking Machine Assembly.”

I’ve been watching those in anticipation of getting up and running. I recall a segment on testing the limit switches. Looked pretty straightforward.

Keep in mind that I haven’t even finished assembly, so I don’t actually know anything.

1 Like