Limit switches not working?

So I bought an XXL and have been using it quite a bit with vcarve pro and love it! The only problem I do have with it though is that I bought it with limit switches to make homing much easier but they maybe worked 1 or 2 days at most when pretty much every axis starting just bumping the ends of the machine, x axis, y axis, and z eventually follow as well. I ended up just disabling them and just move the machine around by jogging it but would like to get this function back up since I did pay for it and all lol. Any ideas on if this are just bad switches I got or is there something else that went wrong?

Please start by checking the wiring — anything loose?

Then please try manually testing the switches — could be that they’re bad.

The other possibility is misconfiguration of soft limits — please see the instructions at:

If none of that helps, or you have a bad switch, contact


It is odd that they worked, and now don’t work, but we can fix it.

Double check the white connectors at the board are inserted correctly.

Is Homing set to TRUE in the settings?

Is there any visible damage?

Send a picture to support @ carbide3d if none of the above solves the problem.

Switch mounting

Connectors at board

1 Like

Once I’m home today I’ll try everything again and see if I can get it work and if it does its bump and run ordeal then I’ll video it. Thanks for the quick reply

Apparently my limit switches just wanted a break. I finally got around to messing with the homing again last night and re-enabled it all and voila, it works beautifully again. I went through the installation once more before trying it out and push on all the switches to make sure none were stuck and then pushed each axis against where it would hit to make sure they had contact. Not sure why they went full retard before but they work again and I’m happy I can rapid position this thing once more. Thanks for the support fella’s!

1 Like

So back to having this problem. Z axis all of sudden doesn’t want to home correctly. I uploaded a video to YouTube so this can be seen

Please contact — we’ll work this out.

Just bought xxl and have same issue with the homing failing. I Checked all limit switches for adjustments all look good and working. But dont see them light up. The error 7 says GRBL error Homing failed, couldn’t find limit switch. I tried calling customer support and left vm’s 2 days in a row and sent emails. No call back or replys. Frustrated as hell.

How did you check?

I’m not seeing any open tickets under your name (the most recent ticket has an answer 16 minutes after you posed the question), and I don’t see that you asked about homing switch difficulties.

Make sure you’ve sent the machine configuration:

There is a basic page on troubleshooting the homing switches at: ​ There is also a Carbide 3D Answer video:

​Please check that the switches are plugged in correctly, and work properly — when the machine powers up the homing indicator lights should flicker on/off, then once the controller is booted up you can test the switches by pressing them — the matching light should light while the switch is pressed (closed), and should go off when the switch is released (open). ​​

Please make sure that the machine can mechanically close the appropriate homing switch on an axis before reaching the limit of travel along that axis — if it can’t, it should be possible to adjust a problematic switch’s placement by loosening the hardware in question, pulling it into a better alignment and then tightening it. The machine being out of square can also affect this, squaring up the machine, or more expediently, securing a small block or plate for the homing switches to contact may be necessary.

After checking a few youtube videos on testing the limit switches I found Z axis limit is not working/ led not coming on. How do I get a replacement?

to get a replacement contact support they’ll most likely ship you a new one quickly

1 Like

Every time I call it goes to voicemail. I leave a message and dont hear back. I will keep calling

Please e-mail us at