Loading a file, first attempt

I converted a JPG file to vector in illustrator. I save a couple of different types not knowing which will work. One did open but I’m stuck on Homing machine. Any suggestions? is there a better .file for carbicemothon3 ?

why is it just stuck on homing machine?

As far as I know you can import a jpg right into meshcam. You need to do that first to create a toolpath, save it, and then open that in carbide motion.

If your machine is stuck on the homing screen, maybe there is a connexion issue? Try restarting your computer and turning the nomad off and on again.

Also make sure the machine is powered on and that the emergency stop is not pressed in.


the stop was in. thanks Now I’ve zeroed the machine but It will not load my file. I opened it in mesh cam and saved it but is still won’t open it in mesh. I’m probably over thinking it. should I go back to photoshop and make it a particular size? I keep getting the 300 pixel warning. I made it 150 and saved it. but that wouldn’t open in carbide motion. I’ve got .png .dwg .jpg .ai .bmp .svg .eps any suggestions


Here’s a quick walkthrough example - maybe it will help. I’m using a screenshot of a font I liked - but this would be the same with any image.

Goto File - Open in Meshcam

You can probably leave this next part the same, assuming your file isn’t too large. I would just click okay. The Black Z+ and Z- will tell MeshCam if you want the black part of the image to be raised above the surface or cut below it. I chose Z+

This is what it looks like when you open the file

You can resize it and move it around

Click on Tools, and then “Carbide Auto Toolpath”

You choose your stock and MeshCam will create a toolpath for you

These are the toolpath options - you can modify them if you need to (at first you probably don’t want to)

This is what the toolpath looks like for this particular image (letter)

Lastly, save the file (give it any name) and it will save it as a .nc file.

This .nc file is what you load as your project in Carbide Motion.

Once you get this far, let me know - I can help walk you through additional settings. For example, you need to set the size of your stock and place the cut on it.

thanks for helping me Darren. I get the big green and red arrows in step 3. I don’t understand the resize and move it around caption you offered. I’d like to eventually make this about a half inch or smaller. I’m only interested in just cutting out the out line of this leaf I’ve got an undefined feed rate, now it’s stuck on measuring the tool. I’m trying to do a contour cut with a V groove tool

sorry I seemed to have miss your final instruction about size of stock and place the cut

I just posted a video tutorial that should answer a few of your questions - check the newer posts in the forum.

And if you just want to cut the outline - I’m not exactly sure how that would work. Perhaps you need to squish the model down so the height is the height of the outline cut and define machining areas from there. I did something similar to this with letters on wooden blocks - check my post about it.

so far I’m in carbide motion. I’ve saved my file in mesh cam and installed cutter zeroed machine and began project then it crashes. did I do something wrong in mesh cam? I sized the stock at 1 inch but I didn’t place a cut on it. It just said begin cutting

Try removing carbide motion from your computer and do a fresh install.

Hi Michael,

Have you gone through the initial tutorial yet for cutting the wrench, the 3d engrave tutorial, or reviewed some of the MeshCAM support documentation? I’d highly recommend going through those before embarking off into new territory, as tempting as it is to launch into your own projects right away :wink:

In particular, if you’re looking to cut flat reliefs, this 2D part tutorial explains the settings you’ll want to use in order to generate tool-paths for that.

Also, when loading an image it wants you to set the size that you intend to engrave the image (X by Y dimension, Z maximum depth) and then at what DPI it should calculate the image. What it’s saying with the 300 dpi warning is that the default scaling of the image which resulted in a DPI over 300 may take your computer a long time to process, so you probably want to enter “300” or a lower number into the DPI field, and then check the box to allow re-sizing.

Once you click OK it’ll convert your image into a 3D relief mesh. Then you can move/rotate/resize/slice that using the row of buttons under the open button, and then do the CAM specific tasks of stock definition, etc. with the buttons in the next group below that.

Does that help?

I can’t seem to get that page to open I’ve restarted my computer, closed browser. no luck

I’ve reinstalled carbide motion but do you think my problem is in mesh cam? carbide crashes when i begin. I’m trying again after the reinstall.


no luck with wrench. carbide crashed again. I guess it didn’t like what I did in mesh. I homed and zeroed and began cutting … crash. I’ll open mesh and try to go through the instructions again


my project is just like the wrench, just cutting out a contour, but with the 60 degree V groove tool. should I use firefox or can you send me the file email attachment?

It didn’t crash this time but this window opened and then it started the program all over. insert tool, measure tool, home, zero. load project etc. It ignored that I had already done that. I’m not understanding the settings and sizes in mesh cam. I’ll try to reload the 2D tutorial again. safari is having trouble loading it with my bandwidth.

Darren, this is backing up the thread a ways, but I have a few suggestions that might increase the efficiency of machining your letters.

  1. You are already using PNG as your bitmap format (good, becuase it doesn’t have the JPEG artifacts at the B/W interface), but make sure that it is a 1-bit image. Pure black and pure white and nothing in between. Newmichael, this shows up on your leaf also with the little divots in the top surface.
  2. For 2.5D images like this (flat-top, vertical walls) use a flat cutter (unless, of course, you want the “woodblock” ridges that finishing flat surfaces with a ball-end creates). With a flat cutter you can check Don’t Machine Top of Stock in the finishing area, and assuming you have the surface of your letter at the top of the stock the finishing moves will avoid that. Since waterline and pencil are defining the actual letter outline, you can increase the parallel finishing stepover to up to 50% of the cutter diameter for the flat recess cleanup.
  3. Uncheck Use Parallel Path in the roughing area. The roughing moves will flow outwards from the geometry outline whicn will be more efficient than the “lawn-mowing” that parallel roughing gives. This will result in less deceleration and acceleration from the many sharp corners.
  4. Change the Machining Margin to 0. There is no need to take the tool centerline outside the stock outline. That is true for both ball and flat cutters.

Hi Michael,

Sounds like you’re having a tough time there on both a technical and a process front, so whereas Randy has chimed in about how to tackle the task, I want to help you with the preliminary setup & technical bits. A few things that may help out:

  1. When you’re jogging the tool around and setting your zero, where are you putting the zero position relative to your stock? If you’re setting zero the the front-top-left corner of your block in the Nomad using Carbide Motion, are you also setting the “program zero” to match in MeshCAM? You set the program zero with the upper-rightmost button in the tool-path section:

    You want to make sure your zero-positions match, because otherwise the location of the cutting paths in space won’t be in the right place, and you might cut into something you didn’t intend to cut.

  2. When the machine hits against a limit switch, you need to a) turn the Nomad off (with the toggle switch next to the power cord) b) close Carbide Motion and then c) physically move the gantry out away from the end of the axis it ran up against. I’d recommend pulling each axis away from the stops slightly. Then turn it back on and re-open Carbide to reconnect to the machine.

  3. For the wrench, you want to save-as and put the file on your computer. Then you’ll open that file from Carbide Motion. You don’t want to try opening that file from the browser directly.

  4. What version of OSX are you running on your MAC, and what model/year of machine are you running?

I can’t comment on your ISP/bandwidth, but that can definitely be a pain when you’re trying to access an online resource!

thanks guys. I’m setting zero at the left lower corner lit the arrows in mesh. I was able to load the 2D with firefox and saved the perimeters. opened carbide and went through the process to begin cutting and the limit switch hit again. I have osx 10.9.5 I’ll check again in mesh and see if my zero is different. I’ll also save as the wench and check that out


that wrench will not open, will not save, if I try to open with and application, mesh cam is not highlighted. will not drag on icon. Maybe be I’ll make sure it the MAC version and try again.