Loosing z-zero position after stop

I don’t know why but after stopping the job, the machine still remembers zero position in X and Y but not in the Z ax. Why? Is it normal? I had a nice piece of wood, and this is the result when I came back to my workshop and wanted to continue.

Martin, I’m only a month into CNC, but my Shapeoko Pro remembers X, Y, and Z over a power cycle. More experienced people will have better insight, but a couple things come to mind:

  1. any chance your “safe Z” height (or retract height) set in your job is above the top of travel? That happened to me when working on a thick piece, causing the Z axis to crash into the top (making a brief grumble sound) right before starting the job. The controller then thought the router was higher than it was, and it promptly burrowed into the piece.
  2. has your router bit loosened in the collet and and worked itself out a little (become longer) during the job? This also happened to me, causing bit-burrowing.

The controller definitely remembers the latest set Z too, but in addition to what @RLampron said, a couple of other possible causes:

  • did you change the tool between that initial job before you stopped the machine and the job that failed ? While the machine remembers Z zero, if you change the tool and forget to re-zero Z, the Z zero will be off since the new tool does not stick out of the collet by the exact same length as the first tool.
  • do you have a bitsetter ? If you do, you must make sure you explicitly use the change tool button (or follow the tool change prompts) when swapping the tool. If you just manually swap the tool for a new one, the machine won’t know that a new tool has been inserted, it will still use the tool length reference of the previous tool, and Z zero will be off for a similar reason than in the previous point.
1 Like

Thank you for your response. What does it mean “Power cycle”. When I finish the job and leave the workshop, I still flick off the main switch, which disconnects the whole workshop from power. When I come back, I switch it back on. The machine remembers X and Y positions but not Z. Does it mean that I can’t switch the power off?

And answers to your questions are no and no.

Yes, I have got a bit setter and I use it constantly. I just put V-bit there and followed the prompts. The machine set z zero position by bit setter and after moved into a position where toolpath should start. And after happened what you can see in the picture.

Great question–for me, power cycling means turning the machine off with the emergency stop button on the front and powering down the PC, then later turning them both on again. I think the home X,Y,Z values are stored in Carbide Motion, not in the Shapeoko; if so, they would be stored on the computer’s drive (older thread that discusses this: Keeping job zeros?). Regardless, as a software engineer, I would suggest trying to characterize the behavior. Specifically, while noting the Z offset value displayed in Carbide Motion, try some power-cycle tests in which you jog the machine to a location and zero the offsets (no need to power on the router). Determine how much the Z axis value changes, or under what conditions it’s forgotten. For example, does it always reset to the same constant value? Does it EVER remember across a power cycle? What steps are being used to set the value? Just some ideas.

But good ideas, mate. I have to make some research and figure it out. It’s bloody annoying.

Please take photos of your Z-axis motor wiring and connectors, including at the controller and send them in to support@carbide3d.com and we will do our best to sort this out w/ you.

I have started to check where could be a problem with losing z-zero position. Today I set the corner zero position by Bit Zero V2. Everything has been looking great. I loaded a job file, started the job, changed the tool, used the Bit Setter to check the length of the tool and…machine started the job quite high above the material.

That’s the zero position after setting zero:

X is fine, Y is fine but Z is again wrong. I had to set separately a new z-zero position to run the job properly.
What am I doing wrong?

Take a screen shot of your zeroing for the Z. Do you have it set to the bottom of material and are setting it at the top? This would cause the Z to raise higher and hit the homing switch and drive itself into the material.

1 Like

In addition to @MrGNY’s tip (which is a likely/common cause), if this is not it, make sure you only ever change the tool when prompted OR explicitly using the change tool button in CM. If you inadvertently swap the tool at any other point of the workflow without “telling” CM you did, the Z reference will be thrown off.

1 Like

I do it every time. I absolutely understand the basics of how the machine works. I understand that I can’t change the tool without letting the machine know that I did it.

That’s my starting position for the setting z-zero position of the corner.

Just a wild guess: are you maybe clicking in CM to set zeroes right after the end of the probing sequence ?
The reason I am asking is because the probing sequence sets zeroes behind the scenes for you, and then retracts the tool above the bitzero’s hole. If you inadvertently click to set zeroes in the menu (as you would when zeroing manually) after that, then the machine will pick up the current X/Y/Z values as the new zeroes, which happen to be the correct X/Y but a Z that correspond to how much the machine retracted the tool after probing. And this can end up looking as shown in your picture.

1 Like

If I clicked to set zero, I still would have to click to “Zero all” to set the new zero position.

I noticed now in settings, that I had the stock thickness from a previous job (29mm) there. The new stock was only 15mm. But still, if I set zero position, the machine should start from this position, not from the previous z-zero position.

It’s not 100% clear if you are doing this, but if you are using the BitZero, you should not also manually “Zero All”. The BitZero probe routine does this automatically for you (as Julien said).

Yes, you are right. And I don’t do it. Never.

Where do you set the zero to in your project? Stock top, or stock bottom?

In Carbide Create (free version), it’s still the stock top.

1 Like