Losing steps on Z axis

I’m losing steps on my Z axis, but it’s only happening in 1 direction. The beginning of the project starts fine, but by the end of the project it’s cutting air.

I have read other articles on here and have made the adjustments that I’m aware of.

  • I have put a brand new Z belt on.
  • I have reset my set screws on top pulley where one screw is centered and tight over the flat part of the shaft and 2nd set screwed is tightened down too.
  • I have loosened and tightened my v wheels
  • I have checked for the pulley slipping in the shaft and it is not slipping
  • Z belt is tight and not slipping around pulley
  • I have slowed down my feeds and speeds and its still happening.
  • my v wheels don’t spin loosely
  • router is squared to my wasteboard.

I have no idea what I’m missing or what other adjustments to make. I can hear a grinding/humming noise as Z goes up and down only. X and Y are good. There is no grinding/humming noise when the machine and router are on and Z axis is not moving. The sound only happens as Z goes up or down.

I have followed this community thread and some YouTube videos. What am I missing? I’ve had my machine for a year and never had a problem until now.

Well you have obviously done your homework (kudos for that).
The only one you did not mention is the endmill potentially slipping inside the collet, but…the grinding noise is not compatible with that so let’s cross it off the list too.

Does the grinding noise on Z happen when you jog it in the air from CM ?
How much force is needed to make the Z axis stop/skip if you “hold” the router mount while jogging up and down ?

Can you maybe share a video ?


Hi, I’m new around here but I have lurked on the forum for quite a while. One thing I noticed missing as another possibility is the retract height being set too high which I have seen cause problems in other people’s posts. Could this also happen if you try to go too deep and run out of travel? A noise has also been associated with that issue on other posts.

Just kinda grasping at straws as I am new to this machine myself, but figured I would throw it out in case it is helpful.


All above advise is good.

Have you powered the Shapeoko off and moved the Z carriage up and down manually. If there are any tight spots that could cause lost steps. Remember to move slowly and evenly both directions.


The collet is holding the bit in tight too. I marked it and it’s still in the same position after Z has moved. I will jog it in CM when I get home and check that out. Driving home from Mississippi now.

Retract height I have lowered it to 3 instead of the default 10.

I have manually moved the machine after powering off. It doesn’t skip or make any weird noises, but it is kind of tight. I thought that’s how it’s supposed to be.

If anything, Maybe my Z belt is too tight. Is the Z belt being too tight a problem as long as it doesn’t bend the shaft? I tightened it pretty good without bending the stepper shaft. It is guitar string tight. So I thought it was good.

1 Like

How loose or tight is subjective to the individual moving the carriage. Maybe try loosening the v wheels at the bottom. The adjustment of the v wheel requires that you use an allen wrench and a open end end wrench on the eccentric nut. Loosen the allen screw a little and adjust with the wrench. Once you get the v wheel in position hold with the wrench and tighten with the allen. If you tighten with the allen without holding the eccentric nut the v wheel will be over tightened. Loosen the eccentric nut until the v wheel turns freely and then tighten until it just stops. Then hold the nut and tighten the allen screw. You could take the v wheels off and inspect them visually for any pressed in saw dust and/or cracks or broken wheels.


I took a video, but says it can’t be uploaded on here. How do I get around that?

It doesn’t seem to take much force to make the Z axis skip by holding the router mount. That would explain why I only lose steps in 1 direction… By the file cutting fine at the start, but always cutting air by the end.

It does feel tight though when I power machine off and move Z manually. Takes a lot of pressure, skips when it first moves then moves smooth.

So I assumed it’s too tight, but forcing Z to skip steps by holding the router mount seemed to not take much force so it kind of contradicts itself doesn’t it? I’m so confused. I have taken Z plate off a few times and I’m about to do it against to triple check everything listed above. I’m not sure what else I’m supposed to be doing.


Hi @CrazyCasey,

If it’s short/small enough, you may be able to zip it and post the zip file. Else, do you have an online storage (e.g. Google drive) that you could use ? If you have a youtube account, you can also easily upload a video there and get a shareable link to post here.

Well except if maybe 90% of the motor torque goes into fighting excessive mechanical resistance, and then it will just take a little extra force (your hand or plunging in the material) to bring it to a halt (or at least losing steps)

This right there sounds strange to me: when the machine is off, you should be able to slide the Z axis up and down manually (but gently/slowly, always) with little force…and with no initial resistance.
if this is not the case, then something mechanical is wrong. I have not heard of a case where a Z-belt is too tight, at least not enough to cause such a resistance.
Can you check if your loosening your Z-axis V-wheels a bit helps getting a smoother movement (with the machine off…)?

At this point, unless it turns out to be as simple as loosening things a bit, you should contact support@carbide3d.com and they should be able to have a call with you to troubleshoot this! Sometimes a live chat/video can identify the problem in minutes.

1 Like

Thank you Julien. I’m at work for 7 more hours and will adjust the V wheels again when I get home tonight.

When I replaced the Z belt and double checked my set screws, I blew all the sawdust off the V wheels and wiped the rails down too. Then I readjusted the V wheels and initialized the machine. It ran for a minute, but still made that grinding/humming noise. This morning was when I powered the machine off and did the manual movements you suggested and then powered back on to test resistance holding the router mount. While machine was turned off, I’ve never had it so hard to manually move Z axis up and down. I’ll readjust the V wheels again to where the don’t spin freely, but just tight enough to where I can move Z axis up and down by rolling my finger across the wheel. I’m really hoping I just missed something or did something silly.

I have the V wheels lose on the Z plate where there is slop. I’m still struggling to move Z up and down when the machine is powered off. So I’m going to snug the V wheels again and mess with this belt again.


Do you have the belt in place?

Might be worth checking that the entire spindle mount plate part of the Z assembly rides up and down cleanly on the fixed rails without the belt engaged on the motor at all, that will isolate whether there’s a rail / wheel alignment / dirt problem or whether it’s some interaction with the belt and motor? That should be nice and smooth, without being loose or rattling around.

After that check the stepper motor pulley turns cleanly with the machine powered off (don’t spin the motor fast with the machine off, just slowly)

Which reminds me, when you try to move the axis with the machine off, does it move smoothly for a little bit and then violently judder as if somebody put the brakes on? If so then try to move it more slowly.

Stepper motors work as generators when spun and they back-drive all the electronics via the protection diodes in the stepper motor drivers and end up powering up the drivers, which locks the motors. Really try not to do this, it can be let out the magic smoke bad.


Yes the belt was in place. I didn’t even think to try and see if it rides smooth without the belt on. Thank you!

The judder starts at the beginning. It takes a lot of pressure to move Z up and down so it jerks and starts as a judder then rides smooth. I may have accidentally engaged the stepper motor when the machine is powered off by forcefully trying to get Z to move. When it does finally budge, it jumps. Near impossible to move it slowly when it’s that tight.

I will take the belt off when I get home from work and go from there. Thank you Liam!

1 Like

When you move the stepper motors with the power off they do product emf because of the nature of a stepper motor. However slowly moving the carriage should not cause you to feel the stepper motor. Only if you move it fast does you see the emf behavior.

Sounds like you have a mechanical problem and until you get the carriage to move smoothly running it under power will only lead to frustration.

If you take your Z axis off check the stand offs and make sure they are tight. I mean the two idlers right outisde of the belt idler.


I think I finally got it!

I took the belt off and the Z axis ran smooth on the rails. So I put the belt back on and loosened it. I was able to successfully finish the project I started. I will cut another one tomorrow to make sure nothing slips.

So ultimately it was the belt being to tight🤦‍♂️ doh!
Atleast I know all the other components are good, properly adjusted, and cleaned now.

Thank you guys for the help and being patient to help me solve this. :facepunch:


The best tip for troubleshooting is to not assume anything and start at the beginning and check each thing. Isnt it funny that the last thing you do is always the fix, so why not just to to the end and you are fixed. :upside_down_face:


Excellent point.

I’ve tried to use such concepts when troubleshooting and wrote up about this here:


Troubleshooting anything is a lot like cutting a pie. :smiley:

Most folks will cut a pie in half first. (Look around and see if no one is looking. Eat one of the halfs.)

Then they will cut one of the halfs in half. (Look around and see if no one is looking. Eat the half that’s left.)

Then cut the other half in half. (Look around and see if no one is looking. Eat one of the quarters.)

Then keep cutting each piece in half until the problem is solved. (Look around and see if no one is looking. Eat a piece until someone gets wise.)

See? Troubleshooting is actually fun. :smiley:


Sounds like the pie being too small might be a problem.

1 Like

so you are saying it takes an infinite amount of time to troubleshoot anything. That is depressing :slight_smile:

Nope. It takes an infinite amount of time to troubleshoot NOTHING!