Losing z-axis zero mid job

Hey guys, I am seriously stuck, I’ve been using my shapeoko for quite some time now and I’ve run more jobs than I can count but recently, in the middle of a surfacing job, I’ve been losing my z-axis zero, at least that’s what appears to be happening. It’s the first time I’ve ever had that happen, but only on the surfacing jobs I’ve done. Had to do it for walnut pieces to later run other jobs and at first it was simply going up maybe a millimeter or two in random parts of the job but not every one I was running so I didn’t really think much because I could rerun it and it would be fine. But recently on the last ones it’s dropped by 5-6mm on three different pieces of walnut. I haven’t used the same toolpath for every run and I went through the whole toolpath that I used most recently and there are no errors. I’ve tried reducing potential noise, changing computers, using ugs instead of motion, still randomly losing the z-axis zero mid-job. The only thing I’ve noticed is the last time I ran it, while returning to the other side to start cutting again, it seemed to gradually go down very close to my piece but I’m not sure, it may have only seemed that way because my piece of wood was warped, it could have not been high enough from the beginning of that rapid movement. I’m open to any suggestions because I cannot figure out what’s wrong.

First and foremost, you need to figure out if when this happens, you have lost steps or had the endmill slip in the collet. Right when you notice this, stop the job and manually jog to where you zeroed initially. If you are not at 0,0,0 then you’ll know, and we can go from there to troubleshoot?

1 Like

Just ran it again and this time it only dropped maybe half a millimeter at the 7th pass (bit isn’t slipping in the collet). Manually jogged back to my zero point and it’s what it’s supposed to be, and it’s also at -1mm from the zero where it’s been surfaced like it should.
I do understand that means the zero isn’t being lost but not sure where to go from there. The belt is tight and not slipping (just took it apart to clean it and make sure everything was adjusted right, it’s a shapeoko 3xl)
Maybe it’s the motor but not sure how to check that ? And don’t see why it would just start doing it randomly on my surfacing jobs unless if I messed it up on the last job I ran before it started.

Thanks

If the zero is still correct after the cut, a typical culprit can be sub-optimal workholding and/or sag of the wasteboard (such that when the endmill is pulling (upcut) or pushing (downcut) on the stock during the cut it moves a bit from the rest position it had while zeroing (and later while re-checking that zero)

When you are at 0,0,0 check whether you can see a visible shift in the surface level if you (gently) push or pull on the stock ?

However it’s not something that would start happening out of the blue…

Afraid that’s not the case, I even have another support underneath the middle of my wasteboard.

And the offset occurs randomly during the surfacing job? As in, it is running the surfacing normally, and all of a sudden in the middle of a given pass it will cut deeper/shallower than the rest of the pass? and if you then stop the job and manually jog to zero, that zero is still exactly where it’s supposed to be?

(to answer one of your previous question, it can’t be the motor: if it was, that would be lost steps, and the zero would be permanently shifted)

My only remaining guess (but it’s a long shot) would be if the pulley set screws on the Z axis (you do have a belt-driven Z axis right?) were semi-loose, and allowed just a little bit of slop under cutting force, but also allowed the pulley/axis to realign itself when the cut is stopped (like a pseudo-backlash effect)

Or just backlash ? but 0.5mm is a lot.

1 Like

If there is room some people replace the tiny 3mm screws with 3mm x 10 mm cap screws. The cap screws have a bigger head and is easier to tighte. You can use removeable thread sealant, do NOT use permanent.

Yes it’s a shapeoko 3xl with a belt driven z-axis.

The shift is completely random during the job, only last time did it go down 0.5mm, the three times before that it went down by 5 or 6mm, and another time before that it moved up by 1 or 2mm three consecutive times in the same job.
Although it’s never in the middle of a pass, it always does one, does a rapid back to the other side and then on that cut it’s up or down by however much.

I would have to check again but I think it still does it even if I’m cutting in both directions.

As gdon said, it sounds like a loose pulley. Did you check the set screws? Sounds like the shaft spins in the pulley and catches and is good again.

Yep, that was my gut feeling in yesterday’s post and based on today’s info it seems possible (i.e. if it only occurs between left/right passes, it happens during Z retracts, and therefore the Z pulley and its set screws is a good lead).

@bwinslow an easy way to prove this is by drawing a straight line with a marker across the pulley and shaft, and next time you see that offset, inspect that line. If there was slippage you will see it there.

1 Like

Ok thanks, I will have to check that.

Going back over previous times that it dropped a lot, I remember that one time after it dropped I went back to zero my z-axis to redo the job lower because I had some margin and so I went down what was supposed to be 5mm and it was a lot lower than it was supposed to be so I would assume that means it lost the z-axis zero and that the motor is indeed possibly messed up ?

99.9% probability that the motor itself is fine. Losing Z reference can occur either due to something mechanical like a loose setscrew, or actually “losing steps” at the motor just because there is excessive force being applied on the cutter, and the motor torque is not enough to continue moving the axis. But that last case has no impact on the motor itself.

If when you go back to Z=0 (or another known Z reference) and you can see that the tool is not actually where it’s supposed to be, that’s your sign that the Z reference was lost due to one of the reasons above.

Alright, thanks for all the help, I’ll have to try a couple different things to see if I can figure it out. I’ll get back to you when I can.

I’ve inspected the z-axis motor shaft and I’m not seeing any marks, no sign of slipping whatsoever and the belt isn’t slipping either it’s nice and tight. I should probably still try marking like you said Julien just to be a 100% sure.
Although to me I don’t really understand how this would be the problem because it’s changing in between passes during my rapid back to the other side of my piece so there isn’t any resistance going on there.
The last time it went down about 5mm it seemed to go down gradually on the rapid, I was watching it and it was slowly getting closer to my stock on the second half of the rapid back over but I only reacted when it started cutting way lower than it should have been.

I wonder if it slips during the Z retract right before moving to the other side. And then if the set screws are semi-fastened, the vibrations during the rapid to the other side may allow the Z to “slip back”. It’s unlikely, but a semi-loose set screw (or one that is tight but not against the motor shaft flat) can do weird things to the Z. Definitely do the marker test to at least be able to rule that out?

Is the retract distance too large causing the Z axis to exceed its travel limit? This could cause lost steps on the way up leading to deeper cuts.

1 Like