Lots and lots of Homing - normal?

Today’s FNG question:

I just upgraded my XXL to grbl1.1 and CM V4 (because why not). I’ve got limit switches of course, but the machine seems to want to do it’s homing operation a lot. All the time. Every start up, after every job load, after every job stop, sometimes between the jogging and load screens. Being a complete newbie to the world of Shapeoko CNC - is this normal?


AIUI, the software was originally designed for the Nomad with its tool length sensor, and because of that, out of an abundance of caution, it re-measures whenever there’s a possibility that the user might have changed the tool.

It may be that this logic will be adjusted — if one is doing production, then one can edit the files to cut down on some of this, or use a different program which is more user-controlled.

1 Like

Ahhhha! Yes, that would explain it for sure. Ok.
I’ve used grbl panel for a few simple jobs and it’s worked well enough. Though I need to get my mind around the homing procedure there, as well as setting table size limits so I don’t go crashing into rails with overzealous jog commands :open_mouth:

1 Like

Following up here… I notice when I do run a homing procedure (either from grbl panel or cm) the machine runs the Z correctly (up, hit, back off), the x runs, hits and stays. Then strangely, the Y stops 3-5 inches from the back limit switch and just sits. A second homing command causes it to repeat Z, X, then finish Y and all is well. Something funny with my XXL?

The defaults were set back in the days of the 16x16 SO3.

Please try increasing the homing seek rate ($25) — it’s set at 1000 by default, try setting it to 1500.


Well dang. Fixed. Cheers!