Loud Stepper Motors and Microstepping

Hello! My Nomad 883 Pro is very loud one of the reasons it is so loud is just it’s stepper motors. IIRC sound from steppers are usually come from low microstepping. Is there a way to change microstepping, say to 1/8 or even 1/16? Hardware is mostly custom made and i am not sure if there are any jumpers.

As an alternative route - can i assemble my own GRBL board with Trinamic drivers and different microstepping. Will it work? How to wire custom BLDC motor controller to an Arduino UNO?

Here is a video of empty machine and simple homing movements: https://youtu.be/Blu31FJXEs8

I can hear stepper sounds from different building ~50 meters away without common walls.

Anything else i can do?

Thanks!

Yes, you can do so. It’s not terribly hard, but it does take some time.

BDLC motor controller… yes, it connects to the same PWM output that standard GRBL provides.

I think there’s something wrong though - I wouldn’t expect the steppers to be that loud. Mine is pretty quiet with the door closed.

I tried to flash GRBL to Uno and connect to it from Carbide Motion, but it refuses to connect. Anything else i should do?

It works really reliably, so it’s hard to guess what’s gone wrong.

The Nomad should use micro-stepping — I’m pretty sure it’s hard-wired into the board.

Usually if a Nomad is noisy it’s because it wants lubrication:

If that’s not it, let us know at support@carbide3d.com and we’ll do our best to sort this out.

Hey @Steve,

I think getting that Nomad oiled up or fixed will be 10x quicker than rolling your own controller, but for your information it is normal that CM does not connect to an Arduino Uno flashed with GRBL (CM expects to find a “Shapeoko” USB device, and ignores other USB ports). If you do need to go further down that route, you can just switch to another generic g-code sender (e.g. UGS or CNCjs) that lets you pick a specific COM port, and it will work.

2 Likes

Ok, i will try to lube everything! Haven’t done this after getting this little beast, hope it helps, but my experience with 3d printers was about the same and it didn’t help much, i just improved soundproofing everywhere to make it tolerable.

But how i can then replicate 1-to-1 Nomad 883 firmware? Support answered me that i should write firmware as is and it should work. What extra step i needed to make it work?

The Nomad uses an embedded Arduino running Grbl.

Carbide 3D contributes to Grbl, and our defaults are in a header file somewhere — if you wish to roll your own Grbl, if you enable the Carbide 3D Nomad-specific defaults it will be exactly the same as ours save for time/date stamps and any updates since we last compiled.

As noted, the Carbide Motion controller has micro-stepping built in — I’m pretty sure it’s 8x — but at my day job now, so not easy to check.

1 Like

I tried to lube X axis, no effect at all. Sound is clearly from steppers and very little sound from ballscrew. I think table under nomad is to blame, got new one, will see if it helps.

Usually awful noise from steppers is a wiring problem — contact us at support@carbide3d.com and we’ll do our best to puzzle this out with you.