Machine pausing after each retract?

Hey all, I’ve had a little CNC experience, but am just getting my Shapeoko Pro up and running, and am new to all of the Carbide Software.

I’m doing a simple sharpie line drawing (essentially the hello world thing, but from scratch). In Carbide Create, I made a new tool, called it Sharpie, and left everything else alone.

Using Carbide motion, it drew out fine, but I noticed that it was retracting a lot more than it needs to (since it’s a sharpie on paper).

So, in Carbide Create, I set the retract height down from 12.5mm to 2mm, saved it off, and reran it.

Everything worked as I expected, with the pen only lifting a couple mm off the page, except that every time the pen retracts, the machine pauses for a few seconds. (roughly the time it would take to retract the full 12.5mm)

I can’t figure out where that pause is coming from. I’m not great at reading G Code, but looking through the file I can see the different blocks of movement. At the end of each is a retraction to +2mm, and then at the start of the next is a z move to -0.25mm (my cut depth). I don’t see anything in that G code that looks like a pause? Is there something in Carbide Motion that expects the retract height to be that 12.5mm? Or some other setting for retraction within Carbide Motion?

Thanks

It would be helpful if you uploaded the file.
That being said, the upward Z and downward Z is for your rapids.
It’s a little frustration, but not much you can do about it.

When I run the simulation you can see the Toolpath in Green and the rapids in Red (Sorry if I mislabel the colors I am colorblind.)
Even on this pocket cut of the elk it has rapids.

Each rapid the machine moves up and down on the Z Axis.

2 Likes

I understand the need to retract to rapid to the next spot. That’s not the issue.

The issue is that it retracts on the Z, waits a few seconds, and THEN rapids to the next spot.

This is a series of hand drawn letter, so just like writing by hand, every time it makes a stroke, it picks up the pen, but instead of making the next stroke immediately, it waits a few seconds, then makes the next stroke.

Here’s a video of Carbide Motion’s Job panel as it goes, watch the Current Line, line, and the Progress %. Sorry for the radio going, but you should also be able to hear the steppers in the background, and the pause each time.

And I’ve attached an .nc file. I don’t know if it’s exactly the same file that was running during the video above, but it’s a file I just ran and see the same behavior with.

Handwriting.nc (4.2 KB)

Since this is a Sharpie, kill the M03S1 lines where they aren’t required. You are probably seeing the spindle ramp up delay. It looks like there is a M03S1 before every X plunge, also an empty comment ().

1 Like

Easy enough to edit a single file, but is there a way to get Carbide Create to not export M03 lines at all? I put 1 in as the RPM, does putting 0 in make the line not write out?

Those empty comments are also being auto generated by Carbide Create, is there a way to avoid them?

In Motion, do you have automatic spindle control enabled?

1 Like

Are each of these line segments a different tool path? If so select them together and make a single tool path that should have one spindle command and path name comment.

I made separate toolpaths for each letter, because I couldn’t find any way to order the cuts within a single toolpath, and I wanted to write from left to right (which it wasn’t when I tried it as a single). Is there a way to order the cuts, not just the toolpaths themselves in Carbide’s software?

I may just abandon Carbide and go work on configuring Fusion 360, but I wanted to at least check out what was offered with the machine.

Neil, I’m not sure offhand, I’ll go check in a bit.

This is a limitation of Carbide Create, you can’t specify cut order of a multiple vector selection. You either live with the algorithms optimized path or manually edit the G-code.