Machine position not showing up in Carbide Motion (used to, now it doesn't)

Using Win 10 on a Surface 3 to run an XXL with Motion. Everything was working great - homing, return to zero - all the good stuff. Then it wasn’t.

I am using a Triquetra touchplate - but only in UGS not Motion. I have tried unplugging it to see if that makes a difference. NADA. Would the simple act of plugging in the Triquetra change something?

I can home the machine, but if jog or do a rapid position, for a split second I can see the actual coordinates but then they zero out.

I am unable to set a zero point. When I try and then return to current position (formerly my xyz zero) it returns to the home position.

Anybody experienced this? I’ve checked all my connections, tried UGS to make sure it wasn’t a Motion-specific thing.

Thanks in advance!



Switched my win 10 surface with the old win8 machine I used to use. Same issue. Without being a rocket scientist or anything, it seems like there is somthing amiss with the XXL’s memory or something else that I don’t understand. Would flasing the machine be a good move?

You should be able to wipe the machine by: