Macros for the bitsetter not updating?

Hi @neilferreri and thanks for all the work you’ve been doing. I use an SO3 XXL and cant seem to get the macros to function for the bitsetter. It runs and probes correctly on both the inital tool macro and then the new tool macro EXCEPT for it never updates the Z! I have tried this on cncjs and on gsender and its the same on both eek

so close and yet so far.

Any insights would be helpful, if there was a way of peeking at the existing variables and how the change that would be helpful, unfortunately that doesn’t seem to be possible as far as I can tell

Are you setting your Z-zero before you use the initial tool macro?

Thanks for the prompt response!

Yeah I have been. I’ve followed the workflow as specified.

Although I’m wondering now, is it it working more behind the scenes and you dont ever see the active working coordinates change? maybe its all not explicitly changing in the work position,etc (which shows relative distance to the zeros? Maybe it’s my misunderstanding somehow, and I should just trust it works before running?

I assume this is not the case, but I haven’t been trying to do this mid program - I would hope that I can simply run in between programs (i.e. this doesn’t require an explicit tool change in the middle of a job?)

To be clear this is my workflow, maybe i’m assuming incorrectly? (i don’t fault the lack of documentation here, I know how things go and I see how often youve answered the community directly - it means a lot)

zero the z
inital tool macro
run program for tool1
new tool macro
run program for tool2

That all looks good. On the new tool macro it’ll just change your work zero. I mainly started doing it this way so I could run the macros during or in between jobs.

To test for your confidence:
Pull an endmill out quote a bit and tighten the collet. Set Z-zero using paper on a piece of stock that you can move away. Run initial tool. Run new tool and put the endmill further into the collet (simulating a shorter endmill), let it do it’s bit setting. Go back to Z zero and slide your stock in there.


Darn. Thats exactly what I’ve been doing and had tried it 4 or 5 times on both programs but I did a restart and it seems to have been a strange quirk!

All good now though thanks much @neilferreri

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.