MeshCAM and Carbide Motion Workflow

I’ve been trying to follow a lot of this stuff for how to use MeshCam with Carbide Motion. I have had several issues. I think what is hardest for me to wrap my head around is the user interface and how it relates to the steps. Are the steps linear or can they be non-linear.
Load file into MeshCAM.
Define Stock
Define top of stock or geometry of file?
Then in Carbide Motion I load file first, then move cutter to define 0 x,y,z, then zero program?
There seem to be many steps that I don’t understand the necessity of.
There are surely special instances where many of these features and all of this freedom to adjust stuff makes sense, but I am still learning all of this stuff.
Why can’t I just say at this point (I move the cutter) it is zero (as in 0X, 0y, 0z) of the stock in Carbide motion. As I’ve already defined in MeshCAM the part inside the stock, wouldn’t it be easiest to just start from that location? I think I need to start with a novice interface that assumes that I know a little bit about the process, but holds my hand through things like surfacing the spoil board. BTW, shouldn’t that be the first task for a beginner like me to start with? I’m not screaming here, just streaming a few thoughts out. I’ve been trying to surface the spoil board without success, just “invalid” errors and some close calls. Thanks for your time.

1 Like

Hi Tem,

Prior to surfacing the board, since they’re pretty flat from the start unless there’s something “off” with them, would be to cut the tutorial parts, which walk you through using the two interfaces.

The general work-flow from Idea to part is:

  1. Import CAD/Image into MeshCAM
  2. Process file to get to creating tool-paths, including setting the program zero position relative to the stock
  3. Export the tool-paths to g-code as a ‘’ file
  4. Open that file in Carbide Motion, and set the physical location of zero in the machine to match what you set in MeshCAM
  5. Run the part!

I think the key idea that you’re missing here is the distinction between MeshCAM, which is for planning and setup of the job, and Carbide Motion, which is responsible for doing what MeshCAM has told it to. In MeshCAM you’re creating and exporting the tool-paths relative to a zero-position that YOU set. Then when you get to Carbide Motion and jog the machine around, you’re telling Carbide where the program zero should be in actual physical space.

So if in MeshCAM you set the zero to the top-center of your stock, you’ll fixture your stock in the machine, and then before you run the job you’ll jog out to the top-center of your stock and set the zero in Carbide Motion to be there, so it knows where to cut relative to that point.

Hope that helps to clear that up!

1 Like

Thanks UnionNine, for the tips.
I actually do understand the difference between the two, but I’m sure that I am doing something wrong, just not what that wrong something is.
The challenge “seems” to be in setting 0 for xyz.
At least, I think I am doing it correctly, but then get errors and strange behavior from the Nomad.
So, I’m left with a murky understanding of the process.
Did I set 0 correctly in MeshCAM?
Did I set O correctly in Carbide Motion?
How do I know I have set 0 correctly?
Why am I seeing odd behavior from the Nomad?

I appreciate your experienced responses!

I finally had a break from work to come back to the issue of surfacing the spoil board.

The whole process seems to start off correctly, but then it doesn’t start milling from the center.
At a certain point, after air cutting almost a square, there is a limit switch error.
I tried the setup a 2nd time, but now I have a step in my spoil board and it is also off set.
At the moment the Nomad is cutting that second step, but I also noticed that there is a small protrusion where the Nomad seems to have skipped out on milling altogether.
Why is it offsetting from the left edge about 1 5/8" and about 1/38" from the front edge?

@Tem, there is not a “correct” place to set zero in MeshCAM. You can set it most anywhere you want. The important thing is to set the same zero in Carbide Motion during your setup.

If you have set your Program Zero in MeshCAM to the top center of the stock, when you set up the run in Carbide Motion you will move the cutter to the center of the stock and down to touch the surface of the stock. Then you need to zero the Carbide Motion coordinates at that point

That is the step that some folks have forgotten to do. Without zeroing the coordinates where the cutter actually is, Carbide Motion will cut the gcode from wherever the zero point happens to be.

Carbide Motion is a numbers-driven program, so coordinating MeshCAM’s Program Zero and the zero point in Carbide Motion is the key to physically cutting in the right place.

(Reading back, this is just exactly what @UnionNine said earlier but it is a fundamental point)

Hi Randy,
Thank you for the advice.
I followed the wrench tutorial process.
But still had the offset X & Y issue.
In MeshCAM I make sure to zero all to the Top Front Left Corner. This is the same location that I zero the cutter in CM.
When I run the NOMAD, CM centers the cutter in a location offset from center. That is what I am not understanding.
Should I zero all first, then move the cutter to the TOP FRONT LEFT CORNER?
In MeshCAM, the origin axis thingy seems to be at that location too, so I think I am setting 0 properly.

How have you defined your stock in Meshcam? Have you set the size to 8" x 8" by 0.5"? I’m asking because from the photo it looks like you may have defined the stock incorrectly - so carbide motion thinks the stock is a different size.

And what size cutter are you using? I can whip up a gcode file that you can load into CM which should, if you zero to the bottom left of the waste board, cut just fine.

And in terms of zeroing in CM - are you moving the cutter to the front left, clicking set zero, then clicking on zero all? At that point all of the values should read zero. So wherever your cutter is at that time, CM will read as zero. I feel like perhaps you are clicking on set zero, but not then clicking on Zero All.

@Tem, your screenshot shows your MeshCAM Program Zero at the front left bottom of the rawstock. Is that what you intend? If the Program Zero were at the top of the rawstock, the green and red axis lines would be at the top.

From your annotated photo, you are setting the Program Zero at the top left front of the sacrificial board. If you are machining the whole spoilboard, that is not in keeping with where you have the Program Zero set in MeshCAM

The toolpath will generally not start at the Program Zero. The roughing toolpath will generally start near the center of your rawstock and work its way outward. So the start of your machining is not unexpected if you are machining the whole spoilboard (facing it to a level surface, for example).

It would help to understand, if you attached a screenshot of your job in MeshCAM.

Okay - here is my workflow that I think is simple enough to follow :smile: It may not be the best way to do things, but it worked well for me.

Step 1: Import an image of a black square and set the size to 8" x 8" x whatever (I’m not sure this matters since we will be changing it shortly, but I set mine to .35") Also check “Black is Z+”

This is what you should see

Step 2: Set the stock size - this is the size of your wasteboard. Set it to 8" x 8" x .35" (although the Z height isn’t as important since we are going to set the max cut depth shortly). Click “Lock stock dimensions”. Also set the Z to zero, so the image is at the top of the stock

This is what it should look like now

Step 3: Set the max cut depth - this is the amount of material you will be cutting off of your spoil board. I have set this to .02" and it has worked well for me

Step 4: Make sure your zero is set in the right place, as shown in the pic

Step 5: Set your machining parameters. Here you don’t want a roughing pass or anything else - just “Cut along X.” You don’t want to set the machining margin too large or else you could hit the tool probe - I have used 1/2 of the cutter diameter in this case. The feed of 40ipm should be fine, and the depth per cut of 10 is fine too. I think a stopover of 1/2 the cutter diameter (in this case .0625) is fine.

This is what the path looks like

From here, all you need to do is make sure you zero the machine properly. I have a way of doing this that’s not so easy to write about - I think I’ll need to shoot a tutorial video soon :smile:

About the zeroing process:
Do I zero out xyz in CM before jogging to the 0 location for xyz on the stock and setting the 0,0,0? Or just locate 0,0,0 on the stock and zero xyz, because thats what I had thought was the process.
By the way, I was not able to move the Z0 location in MeshCAM for some reason.
I was obviously able to crete a job in Mesh CAM but am not able to retrieve the tool paths, aside form an .NC file. I will not be able to access MeshCAM for a a few weeks.

In CM, move the cutter to where the 0,0,0 position is and then zero XYZ at that point.

If you are working from an STL input or extruded DXF in MeshCAM, you can set the zero point with the Set Program Zero command in the CAM menu.

If you are using MeshCAM 6 and working from a bitmap input, you cannot move the Z0. That is a bug in V6. In CM, instead of zeroing Z when the cutter is touching the stock, you will need to type in the Z value corresponding to the stock top surface from MeshCAM (if your geometry is .100" thick, the top of stock is Z+0.100 and so on)

Thanks Randy. So, I am fairly certain that I am doing all these steps in the right order.
Would having the Z0 located below the stock contribute to the offset issue at am seeing when attempting to surface the spoil board?
The problem is the cutter going all the way to the right side and hitting the limit switch.

Z0 difference wouldn’t have anything to do with X and Y. One thing to check is whether the units–mm or inch–are consistent through the workflow. One problem some people have experienced was that they didn’t notice MeshCAM was importing the geometry as mm with them thinking it had been inches. 20mm and 20 inches make quite a difference! :slight_smile: Could you zip and attach your gcode? You said you don’t have access to the MeshCAM machine for a while but the actual gcode will give a good clue as to what is really happening.

Yes, I’m away from my workstation that has MeshCAM. On vacation actually until mid August.

Hi Guys, It still begins cutting about 3/4"positive X from center and 3/4" negative of Y from center. Z is as expected. Why would there be a 0.75" offset in X and Y to begin cutting when the tollbooth preview in MC shows a very centered start location on the stock?
I’ve completed all the steps in order in both ways suggested to me.
Still a huge offset is causing the issue repeatedly.

Finally, an inkling of progress. If I am understanding correctly, the XY center was referencing a slightly oversized spoliboard STL file (9"x9", late night visual delusions? Funny, I never went back to check those DIMs). It seems like this caused the .75" offset.
I also set just an X pass, no roughing. I increased the federate from 5 to 10, so I am getting more chips than curlies. Its humming a bit more, but not like my first try, when I didn’t have one of my wifes old foam sheet yoga matts under it.

Some progress on cheap 12mm thick sheet of HDPE.
It got loose during the last few minutes. I had just used double sided tape, next time maybe something more substantial is news for work holding. The vise might be too small for this size project (145mmx160mm), I don’t know. Regardless I need a 1/8" ball end cutter (I got 2 squares and one was mislabeled on the kick starter delivery). I need to order a bunch of stuff anyway from the store so I’ll be ordering 1-2 more of those any way. I’m just starting to get the hang of how this works. I’m really enjoying the learning aspect. By the way, how do I stop plastic from building up a big wispy mass around the cutter? Thanks!

HDPE is a low-surface-energy plastic, similar to Teflon and Delrin, adhesives don’t stick to it very well. So yes, screwing it down to the spoilboard would help a lot.

The closest I’ve come to machining HDPE is Delrin (acetal) but there is some discussion on the Shapeoko board at The numbers might be agressive for the Nomad, but the message seems to be keep the feed rate up and adjust the depth of cut to not bog down the spindle.

That’s a neat looking workpiece. Is it a surfboard fin?

Hi Randy, yes it’s a type of surfboard fin that fits into a slotted box. the ability to remove the fin for traveling on airplanes is great because they don’t get knocked off or forced theough the fiberglass shell, which leaves the board basically very limited or worthless.
I’ll try pre-drilling the sheet outside of the area to be milled and then use some screws to fasten the sheet to the spoil board. Using the Nomad set-up feature seemed to work very well. Thanks for the speed and feed link, I’ll review it soon.

I had great success with King Starboard (got it at TAP Plastics), a really nicely machining HDPE plastic - only perfect little comma shaped chips, no strands or hairs or melting at all so I never had an issue with stuff stuck to the cutter. FWIW I was able to machine a lot of it quite successfully with just sticky tape, even when trying to stick the bumpy side down. It didn’t stick as well as it did to wood, but it would have certainly worked for that fin you were trying to cut out if you put tape all over the bottom surface. Thought since you’ll need to screw down the piece for the second side, you might as well just drill the holes and screw it down to fasten it.