Meshcam help. Cutting too small on contour

Does meshcam have issue with importing/opening DXF? I created the part in inches, set meshcam to inches and when I cut the part it’s wayyyyyyy smaller. pic below.

I then used an STL and it seemed to be the right size. Cut this out with a 1/8" single flute and the holes are spot on but the contour is pretty far off. Same tool, contour tool path, tool in meshcam is the same.
Tried increasing the stock size, same issue
Did I miss something?

Pic of how small it cut out from the original imported dxf

I use MeshCam for part of my workflow & I’ve found that when importing certain files it does not scale properly. Most recently I needed to pocket out a circle, so I made an SVG of a cirlce with the radius I wanted, then imported that into MeshCam - selecting the correct unit measure I used when I designed & saved the SVG. When I created a toolpath, I noticed that the machining time seemed way too long for what I was doing. So I looked more closely at the size of my circle in MeshCam & realized it was way bigger - 125% bigger. So I scaled the geometry down by 75% to get it back to the size I wanted it to be. So I would agree that there may be a bug in it with regards to 2D file imports - possibly to do with Imperial to metric conversion.


Glad i’m not the only one but none of my stuff is created, exported, or imported in metric.

Got the outside dimension correct. You can’t use the contour for it, had to use the cutout toolpath and it worked. Not sure why contour didn’t.

The other thing that is driving me crazy is the scroll zoom. How in the world do you charge $250/$500 for software and you don’t even have options to change zoom and pan features

This topic was automatically closed after 30 days. New replies are no longer allowed.