MeshCAM showing machining top of stock when Geometry Only is selected

I’ve been using this for a while now but recently came across a little problem not experienced before. When creating the cutting file, the preview of the toolpath is indicating that the Nomad is going to machine the top of the stock and the cut out even when I’ve got the 'Machine Geometry Only" selected and I’m only rough cutting.
I’ve selected the areas as close as possible to the shape I’m cutting but it still indicates the top being cut - very frustrating!!
Have re-booted software and my machine, pc etc but no change and yet I know I’ve machined a very similar cut out before with exactly the same settings but not had this issue.
I must be missing a step of some kind.

The crickets I am hearing suggest this one is a bit of a mystery - and I can’t say I have encountered that myself. Perhaps there is something going on with your STL file? When you first open the STL file in MeshCAM does the geometry size (the bounding box around the part in the display) closely surround the part or is it significantly larger?

1 Like

Its close to the geometry being cut out. And even if I zoom in as close as I can it’s showing the tool jumping up onto the edge of the cut out.
It seems deselecting 3d roughing stops the ‘machining the top surface’ but this also means that it is only showing a perimeter cut out, not the whole geometry (I little like a waterline cut only wider) - it’s very wierd!

Amazingly I’ve just tried again but selected machine whole stock and it’s worked!! It appears that my software is reversed or I have some sort of bug that has swapped these selections?