Minimum Tool depth

I have looked around and haven’t found an answer. Does anyone know the minimum tool depth for the Shapeoko Pro?

I inserted a 1/8" endmill in my Shapeoko Pro, and the homing cycle failed. Tried again, failed again. It sounded like the z-axis was bottoming out. I inserted the 1/4" endmill that came with the machine and had no issue with homing.

I inserted the 1/8" endmill and did not set the tool as far in as before and was able to home.

So, is there a minimum? Or is there a settings/configuration issue with my machine?

Thanks.

I cannot speak to t he pro parameters but in t he Shapeoko 3 the Z-Plus could not go low enough to hit the factory base board on many people’s machines. The limitation of the Z travel is controlled by CM in the configuration. You could try to increase the limit slightly. Just be careful you do not set it so the ball screw bottoms out the Z axis. When you go into the configuration you can change t he X Y and Z travel from the defaults. Just be careful not to over do it. The X travel has been limited in the last few CM versions to compensate for dust collection that has arms that extend past the width of the Z carriage. This is to keep your Z axis from crashing into the Y. You can adjust the travel slightly to get full use of your machine. Again be careful because CM does not stop your machine from crashing into things if you set them beyond the physical limitations of any Shapeoko.

When you set the configuration parameters in CM you are limiting how far you can jog any axis with the jog function. If you write gcode that goes past the physical limits of the machine and use CM to send that gcode the machine will try to carry out the instructions and hit the physical limits and start grinding. When you jog the limits are enforced by CM from the configuration and if set properly will not let you hit the physical limitations of the machine. There are other gcode senders but they do not have the magic smoke inside them like CM. CM is more than a gcode sender and is build by C3d specifically for their machines. Not every function of CM is apparent.

“Homing” as in finding XYZ 0 after initialization is unrelated to your bit; it can do this with no router installed.

Do you mean when it probes the bitsetter for tool length it bottoms out and makes the grinding-like noise? In that case, I suggest you ensure that the router is mounted as low as possible in the mounting clamp.

I have no issue using tiny 1/8 and 1/16th endmills in mine with barely any stickout. I assume you are using the Carbide3D router.

Where is the router set in the mounting collar? You may need to just move it down in the mount a bit futher.

1 Like

There was a post a few weeks ago about a Dewalt Router crashing down on t he BitSetter. I measured my Dewalt router and it is about 3.25 inches from the bottom of the router mount to the bottom of the router body. The Makita is only about 2.375 inches from the bottom of the router mount to the bottom of the router body. The Dewalt user had to move the Dewalt router up in the router mount.

If you have a c3d and/or Makita it is shorter than a Dewalt and will need to have the router moved all the way down in the router mount. Even then very short bits with a Z-Plus may not go down far enough to reach the BitSetter and/or the factory base board.

I am using a Makita router, and it is as far down in the mount as possible.

Pardon my terminology. I should have been more accurate and said initialization instead of homing. They may be independent from each other, but my machine will go through the homing process, then ask me to insert a tool, then continue to probe. There doesn’t seem to be a way to cancel the probing routine, so when my machine initializes, it goes through the homing AND probing process every time. It will probe whether I click continue or close the window with the dialog that asks to insert a tool. If no tool is present, then it will bottom out (and the motor make a terrible noise) and I will get an error that says the homing process failed.

After successful initialization, I can jog my machines z-axis as far down as I can and still have 7/8" space between the bottom of the collet on the router and the waste board strips. Since the magnet for the BitSetter probe is pretty much level with the waste board, I have to set my tool at least an inch out from the collet. Is that in-line with what everyone else is needing to do?

I have set my machines configuration based on the defaults of the machine type that I have. But for my own sanity, what should the XYZ values be in the settings?

Thanks!

No one knows what your machine configuration should be. You will just have to set the Z travel and see if you can get it to go low enough without hitting your physical limit.

Open CM and connect but do not initialize. In Settings are the configuration set up. Go to the second tab and unclick the BitSetter so your can initialize without the BitSetter. Open the configuration and change your Z parameter to increase it. Then initialize. Jog over to the BitSetter and jog down with the Z to see if ou can get to the BitSetter. If you are still short then go back and increase until you either get to the BitSetter or hit your mechanical limit of the Z axis. Dont forget to send the configuration. Sometimes people open the configuration and go to the second tab and forget to send the configuration. When you get it working go back and check the BitSetter to enabled and set up the position.

I believe I am at the mechanical limit of the z-axis. Otherwise I wouldn’t hear the motors grinding when it stops.

I tried changing the z value and sending the config, but there is no change.

@Thinkiverse are you using the 1/8" and 1/16" endmills with a 1/8" or 1/4" shank?

Both with 1/8 shank. Super cheap ones in big packs from amazon; it seems like a waste to buy 1/4 bits.

I apologize for all of the questions… Are you using the BitSetter with those tools? Do they have an overall length greater than the Carbide #102 tools?

With my setup, (router mounted as far down as possible, z setting set so that I hit mechanical limitations, and tool shank push back enough to be flush with the top of the collet… There is not enough tool/travel to probe with the BitSetter. Just curious if anyone else has this same issue/scenario.