Missed spindle speed command?

I’ve just had a near-failure, because my Nomad tried to machine things at 5000rpm instead of 24000rpm.

This was one of multiple operations in G-Code generated from Fusion 360. Fusion normally sets 5000rpm for ramps, but then follows up with actual milling speed (24k in my case) soon afterwards.

For this one operation, however, my Nomad stuck at 5000, and I frantically rushed to lower the feed speed manually.

Everything went fine for the subsequent two operations, so it looks like the machine “missed” the S24000 command for some reason. How is that possible?

I checked the G-Code and every S5000 command is soon followed by S24000. Here’s an example:

S5000 M3
X38.191 Y92.779
G3 X38.382 Y91.201 Z-32.129 I0.683 J-0.718 F350
X39.836 Y91.835 Z-32.258 I0.491 J0.858
X38.814 Y93.044 Z-32.387 I-0.961 J0.224
X37.951 Y91.721 Z-32.516 I0.061 J-0.983
X39.462 Y91.274 Z-32.645 I0.922 J0.339
X39.457 Y92.846 Z-32.774 I-0.587 J0.784
X37.957 Y92.392 Z-32.903 I-0.581 J-0.786
X38.82 Y91.088 Z-33.032 I0.917 J-0.331
X39.82 Y92.285 Z-33.16 I0.054 J0.971
X38.389 Y92.899 Z-33.289 I-0.944 J-0.226
X38.211 Y91.355 Z-33.418 I0.486 J-0.838
X39.738 Y91.627 Z-33.547 I0.662 J0.705
X39.041 Y93.01 Z-33.676 I-0.863 J0.432
X37.919 Y91.948 Z-33.805 I-0.165 J-0.949
X39.254 Y91.179 Z-33.934 I0.954 J0.113
X39.607 Y92.674 Z-34.063 I-0.38 J0.879
X38.078 Y92.584 Z-34.192 I-0.731 J-0.614
X38.601 Y91.148 Z-34.321 I0.796 J-0.523
X39.824 Y92.059 Z-34.45 I0.272 J0.911
X37.922 I-0.951 J0
X39.824 I0.951 J0
G1 X39.828 Y92.239 F800
X39.899 Y92.4

It’s quite unlikely that the machine “missed” a command but not impossible if there are intermittent glitches on the serial line. But I would double-check the Fusion file first, it’s easy to forget to change the default 5000 RPM value. If you create custom tools you can set defaults to higher RPMs

@Julien I agree it is unlikely — I find the whole thing bizarre. That’s why I’m asking here.

I did check the generated G-Code (I can attach it if needed), because a mistake setting up operations is the first thing I thought of. But every S5000 (for ramping) is soon followed by S24000. And my machine clearly tried to perform the entire lengthy operation at 5000.

This happened only once — all my work before and after this was just fine.

Yeah. My point was also that setting ALL RPMs in F360 project to the target value is a way to avoid this (weird) problem, I tend to do it always


I had this happen again and I’d really like to understand why it happens. I understand I can avoid this by setting all my ramp speeds to target speeds, but perhaps this is a debuggable problem?

Here is the complete G-Code. In the “Adaptive14” operation the spindle stayed at 5000rpm. I heard it and managed to save the job by frantically slowing down the feed rate manually. After this operation was completed, the rest of the code was processed normally.

part2.nc (1.0 MB)

Everywhere it did not happen, you declared a spindle direction.(M03) I understand this is how the post is written but what happens if you insert spindle direction after spindle speed in “Adaptive14” ? Does it behave differently? Adaptive15 starts and stays at 24K and did not seem to give you any issue.

T530 M6
S24000 M3
G0 X31.321 Y30.045

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.