More G2, G3, G38.2 issues

Haven’t had this rear it’s ugly head in a while, but here we go. Per the last incident, I followed Rich’s tips:

Open the tolerance (went to .01 from .001)
Min Rad to 0.02 (In Fusion F360 AND the Postprocessor) (check)
Eliminate Helical moves (check)
Break the file into smaller files sizes to pin point the error.
Change the method 2D adaptive to Pocket or something that works (was already pocketing)
Try to eliminate small 3D moves

It seemed to occur after the plunge in a small pocket, right as it started to move in X/Y, and occured in a similar place in several pockets. I isolated one of them, changed my stepover from .125 to .1, and it worked! Applied the same technique to the remainder, and all of the sudden I’m getting an arc endpoint error, which was completely new. I did update to 410 this morning. Code was generated from Fusion. Not sure what is the next best step, would appreciate advice. Thanks.

Nevermind. Increased the stepover from .1 to .13 and it’s running again, for whatever reason. I feel like this process should be a little more precise. Not blaming Autodesk or Carbide at all, I just hate guessing.

@chamnit has noted that Grbl is very forgiving of its error checking for these calculations, so I’d urge folks to send such problem files into Autodesk and get them to fix their end.

There is a check mode for Grbl:

and I think a very nice feature for a G-Code sender would be for it to:

  • do an MD-5 hash of a file when it is loaded
  • compare that to a list of known good file hashes
  • if the file hash is not found, run the file through the syntax checking mode of a local copy of Grbl
    • if okay, store the hash and proceed
    • if not okay, announce that fact before cutting begins
1 Like

I couldn’t find the issues thread that investigates this problem. It turned out there was a bug in the Fusion360 post for Grbl. It was generating arcs that were completely invalid, where the target end point would be no where near the arc radius described. I found some posts worked fine, others had this problem. I didn’t dig deeper to figure which ones but I recall the current (at the time) default post for Grbl worked. While a user version that has been floating around doesn’t. Hope that helps.


I appreciate the input.

Perhaps that discussion was:

Link at:

I’m afraid I don’t follow the Fusion 360 stuff closely — too many horror stories about Autodesk resellers back when I was working at a small computer shop.