Motion 417 & HDZ upgrade jogging issue

Hello. Last night I installed the HDZ and upgraded Motion to accommodate. While experimenting with different jog speeds for Z, there is a problem with the 2nd fastest speed (1mm). It jumps in increments much larger than 1mm and will eventually cause an error to appear. The other three settings appear to work - Fast, .1mm, .01mm. My bigger concern is if this error goes beyond jogging and leads to problems with jobs. I can live with the jogging problem until a future release addresses it, and have no choice with HDZ since it only works with 417 (only one beta version available). Anyone else having this experience? Note - I experimented with switching to Inches and had the same error - 2nd fastest Z jog speed does not work correctly.

Have you sent the settings for the HDZ to the machine?

1 Like

If by that you mean did I follow the instructions in the pdf which say to get Motion 417 installed, go immediately to settings, select the appropriate machine, check the hdz box and click save config. The answer is yes. It is a requirement before homing. I watched the log to make sure the save config was working and it also had a progress bar to show it was completed. Finally I also checked the Inputs - x,y,z limiting switches before homing. Homing worked. The only issue I have found is with using jog in Motion on the Z axis in the 1mm (next to fast) speed.

So when you jog by any other amount in CM on Z it moves the correct distance? Can you confirm your $102 setting?

Thank you. Yes, although I did not measure it with a gauge, just experience. The 1mm jump was significantly off, moving more like 5mm with one click up or down. I can’t confirm the $102 setting at the moment (not near machine) but I can in a few hours. What should the value be?

Off the top of my head it’s 320, but can be 160 if you have an older board version.


I get a random error when I use the 1mm setting also. If I hit it three of four times relatively quickly. I’ve not really tried to measure. I did have to loosen and reset the rails, per instructions as mine were not aligned and movement with jog would bind and give error. Since, it works well.
I do know when I tap the touchpad, it may jump twice… and this isn’t only 1mm setting.

$102 for me is 320. Tonight I did a send config again (before checking $102, so I don’t know if it changed) I put a guage on the z axis at 1m speed and it was accurate. It appears maybe the issue cleaned up after the 2nd config.

1 Like

I also tested it in .1 inch mode and it moved an accurate distance on Z.

1 Like