My startup experience

The sound in your video seems like something touching the cooling fan blades. It doesn’t sound normal to me.

There are some small wires that run behind the fan, for example the ones from the E-stop switch. I suggest unplugging the machine then looking through the cooling fan blades with a flashlight, you may be able to see wires that are close enough to touch the fan blades. You might be able to gently push them farther away from the fan with something like a pencil, though I would be very careful as there are circuit boards directly behind the fan as well.

I have had the side covers off my Nomad 883 to fix a small problem, and I did manage to have the limit switch wires touching the fan when I put the cover back on. It made a noise very much like your video. It was easy to resolve by adjusting the wires slightly, but I would not suggest you take the side cover off unless you feel comfortable doing so.

What was the small problem?

I was getting the “limit switch hit” message on startup and the machine was not moving. Having the USB plugged into a powered computer was enough to run the controller board, light an LED visible through the fan opening from the back, and spin the fan a bit, so I didn’t immediately realize there was no AC power to the unit.

It took me a while to figure out that the Nomad was tripping the ground fault protection on the circuit into which it was plugged. It was a simple thing, the ground and neutral wires were switched at the input to the DC power brick inside the unit. I switched them to the correct positions, and no more problems with the ground fault protection. And no more “limit switch hit” messages.

Anyway, I had pulled off the side panels, top, and back panels as part of finding and fixing this small problem. When I put everything back, the wires from the limit switch were touching the fan slightly and it sounded just like the video posted by SkyeFIre. I pulled the side panel off that contained the limit switch, adjusted the wires so they were not touching the fan, put it back together, and now the fan runs very quietly.

1 Like

Thanks. Wow. Thats an odd error to ship with.

I’m guessing that many shops do not have ground fault protection either in the electrical outlet or at the breaker panel. This is the kind of thing that might not show up with the unit plugged into a normal outlet and so could be missed in final testing.

I pointed this glitch out to the Carbide3D team and they indicated they would add a check for this to their QA routine.

So I guess my takeaway is that if a Nomad throws the “limit switch hit” message, along with no brief sound from all the stepper motors when switched on, it’s worth checking the power at the outlet to make sure it’s still on.

I have the same issue with the CNC not getting all the way through the material. It would be helpful to have something holding the material in place instead of tape. What type of two sided tape do you use? None came with my machine, and I have been experimenting unsuccessfully.

I too experience the “machine parameters invalid” msg, which brought me to your post.


This thread helped me get through my startup experience, and I wanted to give some other data points that may help others.

It took me about ten tries to get the wrench cut. In roughly chronological order, here are the things that I did wrong:

  • I tried to cut the piece with the machine not actually on. I was set up in a noisy environment, so I couldn’t use the fan noise to tell if it was working. Carbide Motion happily said that the Nomad was connected - as others have noted above, the control board gets power from the USB, so it apparently didn’t know that the system was not on. The error message was “limit switch hit.” This took me several different tries to track down. When I finally determined that I hadn’t pushed the power cord fully into the socket, this problem went away (although the problem of feeling like an idiot persisted).
  • As a few others have mentioned, I also found that the emergency stop had been engaged in transit. This was easily fixed by twisting and releasing it.
  • I had moved the work surface all the way to the front of the machine, tripping the limit switch. When trying to home the Nomad, it would not move, and Carbide Motion gave the “limit switch hit” error. This problem was solved by powering down the Nomad and manually moving the table towards the middle. Powering up again, and it was OK.
  • Zeroing error number one: When intending to move to the zero position, I tapped Z+ when I intended to tap Z-. I hit the top vertical limit switch, and Carbide Motion crashed. Restarting Carbide Motion didn’t solve the problem: each time I went to move the cutter, it would detect that the switch was tripped, and the program would crash. To solve it, I powered the Nomad down, and manually moved the cutter down off the switch.
  • Zeroing error number two: I went through the zeroing process, but failed to actually set the zero. This was simply bad reading / following of instructions on my part. I moved the cutter to the zero position, clicked on “set zero” and assumed that the zero had been set. I did not set the zero for each axis or click the “zero all” button, but went directly to “Quit Jog.” So then when the Nomad went to start cutting, it shot off to the right until it hit the limit switch. As with the other limit switch errors, powering down and manually adjusting seems to be the best (only?) solution.
  • The mysterious “Machine parameters are invalid” error. Clicking on this the first time is required, and then Carbide Motion tells me to switch the cutter to the square mill. It will pop up the error again after confirming the square mill is installed. I clicked to acknowledge the error message, and it took me back to the “Connect to Nomad” screen. I started the entire process again, and the next time through, I did not click to acknowledge the second “Machine parameters are invalid” error. It worked!
  • I thought I had zeroed the material quite accurately, but I only cut about half way through the bottom aluminum sheet of the composite, so it looks like I was off by 0.1 or 0.2 mm. I cut out nearly-complete wrench with a razor blade.

Tutorials are designed to be learning experiences, and this certainly proved to be the case. I’d say my troubles were 50% getting used to the machine, 25% misunderstanding the issue I was seeing, and 25% software bugs. Not so bad for a first foray!

Thanks to everyone in this thread for cataloging the way that the first run experience can go wrong We’ll be adding some additional documentation, either in the machine or in the tutorial, to warn new users about the common failure modes.

The new Carbide Motion will eliminate the “Invalid Parameter” error and clean up some other quirks. It’s being tested now with new firmware we need for machines shipping to Europe.

Jorge has done some work on the next generation of electronics for the Nomad to make assembly quicker and we’ve added more to the circuit to let the PC detect the state of the machine power. This won’t help anyone here directly, but we do understand the problem and we’re eager to fix it in the future. (Just so you know we are paying attention)


1 Like

I’ve managed to eliminate my fan noise. Craig was correct, it was the green/white wires near the E-stop that were hitting the fan blades. I got them tucked behind the E-stop and now my Nomad is dead silent when I turn the power on (not dead, the fan is definitely spinning).

For those interested, I wrote up my experiences in opening up my Nomad (blindly) in the topic “opening the case”. It was an interesting experience, and one which provides some insight into the Carbide3D teams engineering decisions and tradeoffs. I will say, I didn’t find anything that would me me reconsider the purchase, or recommending Nomads to my friends.

Was there a software/firmware upgrade to take care of the error message mentioned in the first post?

Is there a special kind of double sticky tape we need to get to hold the material down, or will just regular double sided tape work?

Was the depth of cut issue noted in the posts solely due to not having the bit tight in the
collett or was there something else involved?

Software update is in progress. I have a few more tweaks and then I’ll turn it over to Apollo for some QA work.

Any double side tape will work but it’s better to use the kind that doesn’t have any fabric in the core, like some carpet tapes. You really want to avoid getting that wound around the bits or you end up with broken cutters.

It sounds like the cutter was not tight so it pushed into the collet instead of plunging into the material.


1 Like

i get this error with every run. even the wrench. I will try to capture the log for you

You will get it on every run until the software is updated.

You need a fairly strong 2-sided tape, RC servo tape works well, 3M VHB tape, some people use carpet tape.

As for the cutter not going all the way through, several possibilities. I would say the most likely is the Z was zeroed a bit high. But it is also possible the particular piece of stock you got was slightly thicker than usual. If it was only in some areas then the tape was uneven.

i hit just about every mistake you made as well. I also managed to not get how to define the stock location vs my zero point in meshcam and spent and afternoon cutting air just above my stock but not my stock.


I just received my Nomad today and gave the first tutorial a run and… encountered my first ever CNC fail! It was looking really good to start, the first plunge was smooth and effortless, tracing the outline of the wrench was going smooth as butter until it almost completed the first pass of the outline and then stall, clunk, clunk, clunk… the spindle recovered and the job continued but the x axis was now offset by 6mm on the x axis so obviously the x axis had jumped a few teeth. In setting up the job, I thought I had my z axis zero dialed in pretty well, I’ve had a Makerbot Replicator for a few years and got plenty of practice with that and when the job started it moved from home to zero without touching the work piece but that being said, the result tells me that I may have had the z axis zeroed in too close to the piece causing the spindle to stall due to some unevenness in the material at the point of failure where the depth of cut became too deep.

Second attempt, I zeroed z axis 0.1mm higher than before and the job completed 100% without any issues… success!!! The wrench wasn’t cut all the way through and had just the tiniest sliver of material attached which had to be cut and filed away but I’d call it a success all the same. It was a little bit scary with all the clunking with the first attempt (and fail) but nothing exploded or caught on fire so no harm done and the second attempt was near enough to being a complete success so all good there. Now that I’ve had my first run experience, I have some questions and comments that I hope can help improve the first run experience for other CNC newbs…

I assume (perhaps incorrectly) that the wrench tutorial was designed to mill all the way through the material. Given that my spindle stalled on the first attempt and moving z axis zero to 0.1mm higher on the second attempt avoided the stall issue, I would guess that I had zeroed too close to the work piece but then moving z axis up 0.1mm didn’t mill all the way through suggesting that I had zeroed too high. I can only guess that the tolerance in the tutorial is fairly tight and maybe splitting the difference at 0.05mm might have made the difference between not milling through the piece and milling all the way through.

The tutorial says that when trying to zero the z axis, it would be easiest to use a piece of paper to slide between the work piece and the bit and to stop when you start to feel drag on the paper. This is exactly the same method I use to zero my Makerbot so it’s a familiar process, however, opening the door on the Nomad results in Carbide Motion wanting to home the device again and you have to start all over. Am I doing something wrong here? What is the correct method to zero using a piece of paper without losing your position when opening the door of the Nomad?

May I offer one suggestion? Can you add a feature in Carbide Motion to fast move (or maybe not so much fast move but automated move) to zero? I can see that there are options to fast move to preset positions and I do understand that moving to a previous zero could result in a collision with the work piece if the material is of different dimensions to the existing zero setting but so could any jog movement. Maybe just pop up a warning first then ask the user to confirm that they want to perform this action? If collisions are a major concern with z axis then maybe just move to within a safe distance, say 10mm or so, then at least it would not be so far to jog manually?

Potential bug report - opening the door on the Nomad (specifically when using the move function) seems to crash Carbide Motion. What I have noticed is that I get the door open notification then I close the door and am presented with the option to load project or move cutter, so I click move cutter (to continue my calibration) then it says click to begin homing, so I click and then it hangs.

All that aside, I’m really, really happy to finally have my Nomad, it’s been more than a year of waiting but I really think it was worth the wait. I think the Nomad looks even better close up than in the photos and it is so much quieter than I expected! It is currently sitting on my desk only about 50cm from me and the noise doesn’t bother me at all, I think it’s probably even quieter than my old dot matrix printer for those old enough to remember them! Looking forward to some more adventures in CNC on the weekend when I’ll have a little more time to try something else on the Nomad.

you may be having USB connection issues…

For the door open issue see my thread about that :slight_smile: Overriding door open sensor