Need help getting new Shapeoko Pro XXL to communicate with carbide motion

I have my new Shapeoko Pro XXL machine assembled and am anxious to get started with some projects. However, I can’t get the machine to communicate with the Carbide motion. When motion is open and I turn on the machine I get a message "no configuration found for the attached machine, so I know the computer sees the machine. However, when I go to “setup new machine”. I can select the machine type and when I get to the screen to “connect to machine”, it will not go any further. I also notice a red light comes on, located below the USB connector. The red light might not mean anything specific, but I do mention it as a point of interest. I have tried connecting to a different computer and different USB cable, with no difference. How do I get past this point? Any help is appreciated!

The red light indicates USB communication/connection, so should be good.

Basically it should all work as described in:

There is a basic page on troubleshooting connection issues at: Machine operating checklist

Things to check:

  • power supply plugged in — it lights up after being plugged in and stays lit with a steady light?
  • power supply connected to machine and switched on — the in-line switch is small and easily missed (try toggling on/off a couple of times) SO4/Pro — machine power switch is switched on and lights up?
  • machine boots up, controller lights up with power, lights flicker on/off, motors lock?
  • machine connected to computer using USB — computer registers USB device? red/green/white lights on controller begin to blink signifying USB communication?
  • How is the USB connection being made? 6’ or less is recommended, and poor quality adapters cables are known to be problematic
  • Are there any conflicting devices in the USB Device Tree? Even a pair of Bluetooth speakers can conflict

The blue power light comes on and stays steady. The USB cable is the original, although I tried a different one with no difference. On the “connect to Machine” popup page, I do not get the "connection established. There are no other devices connected other than keyboard and mouse. the computer device manager recognizes the connection by identifying it as a Shapeoko 3. It is on COM 4 and defaults at a baud rate of 9600. I read somewhere the baud rate needed to be 115,200, so I tried changing it, but made no difference. What should the COM port and baud rate be set to?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.