Need Help! My S3 just sits there looking at me

Hi, I’ve been using my machine for almost 4 years, and while I do simple things, I’ve really enjoyed it. My normal operation is to draw in SketchUp and create the gerber file with SketchUCam, then send it to my S3 with UGS. My latest project started with a .svg file from someone else for a hole pattern for an electromechanical game. I modified it a little bit, got the latest Carbide Create and imported it, then put in tool paths.

The similation looked great on the screen. I had it generate the .nc file. But when I hit Send, UGS showed lots of lines going out, but my S3 just sat there and looked at me, did nothing. I tried it with simple g-code and grbl selected. I sent an old simple job and it still worked fine, so I think the machine is fine. My S3 sends Grbl 0.9g when it connects, the UGS program version is 1.0.9/Nov. 11, 2015. Any help would be appreciated. Thanks!

Shapeokos now run GRBL 1.1, and I’m aware of compatibility constraints between GRBL version and Carbide Motion versions, but it’s the first time I hear about a potential compatibility issue between Carbide Create post-processor and GRBL version. I’m sure @WillAdams knows.

In the meantime can you double-check in Carbide Create if the selected post-processor (under “Edit”, “Select post-processor)” is “Shapeoko”, and not “GRBL” or “Basic G-code” ?

And maybe upload here the G-code file that doesn’t work, and the earlier one that works, for a quick check?

The problem you describe sounds as if the machine were put into check mode by sending $C

Another possibility is soft limits have been enabled, and UGS isn’t properly raising the alarm state.

Could it be that you were unsuccessful at generating G-Code? Have you compared the working file and the problematic ones?

Thank you Julien & Will for the response. I didn’t select “Shapeoko” because it says it uses the limit switches which I have never used. Attached is the large file in question and a small file which just makes a 3/4in hole made with my normal tool chain. Prisoner game playfield 01.nc (2.4 MB) hole _75 exp 01.nc (22.8 KB)

1 Like

Ah, sorry I missed that info earlier. Makes sense.

Is the new/large G-code file generated using the “Basic G-code” or the “GRBL” post processor ?
Try regenerating the file using “GRBL” and retry: I wonder if the M0 command (which is pretty much the only significant difference in the preamble between the two files) can cause this in UGS, since this is a “pause” command and maybe it reacts to that. Just a wild guess though.

I’m not familiar with the required post/setup for CC for earlier Shapeokos without homing switches, @WillAdams will know

1 Like

Hi Julien, Can one take the action “Edit > Select Post Processor >” at any time, then generate a file and have the resultant file use your latest file type selection, or must it be done before working on your project? I ask that because I seem to get the exact same file whether I select Basic G-code or grbl. By exact same I mean the length and examining the first lines.

You can do it at any time, as long as you re-generate the file afterwards. I really never bothered to learn about what exactly those two post-processors are doing, so it’s quite possible that they produce very similar outputs and I never noticed.

For the sake of science, can you maybe try to manually edit the file, delete the M0;T102 line, and run it, see if it makes any difference from UGS standpoint ? (the M0 is just a pause, which does not exist when using other post-processors, and the T102 is irrelevant since there is no need for a tool change in that file, so it should work just fine without it)

By the way, if you capture the content of the UGS console window upon running the file, do you see any suspicious message in the first lines ?

1 Like

Hi Julien, Yes I deleted those characters, then just set it up simply with no endmill, no motor, and it started moving in the expected pattern! Thank You!!!

I guess I can do this with all my future projects? I looked up M0 and it seems to be a command for full stop. Why is this actually here at all, especially at the beginning. I might understand it at the end? Is there a checkbox I missed somewhere in CC?

In general, which is a better selection, “GRBL” or “Basic G-code” ?

Is it advisable to update my S3’s firmware to GRBL 1.1, my philosophy is usually “ain’t broke don’t fix it” but will happily follow expert advise.

Thank you again, Kerry

1 Like

Grbl 1.1 has the notable advantage of affording feed rate override, as well as smoother jogging.

Drop us a line at support@carbide3d.com if you wish to upgrade.

1 Like

No you didn’t miss anything in CC, and I’m not sure either why that M0 is there or whether it is specifically UGS that does not like it. I also don’t know whether GRBL or Basic G-code is best for machines without homing switches…Maybe @robgrz can tell us (what post processor is best for older Shapeokos).

Hi, I just finished making my board and it turned out great! Thank you so much for your help.
Kerry

2 Likes

You know…I’ve often felt like my shapeoko is staring at me as well…

2 Likes