Need help with vac disconnects

So I have my emi disconnect issues managed by using a tablet that is not plugged in to charge.

Now out of no where A month later I’ve got disconnect issues with my vac on.

It’s a xxl purchased in January of this year( damn this year has been long). I have an hdz and a 2.2kw water cooled spindle. It has a dust deputy inline to a 5 hp shop vac. I have a pwncc dust boot. I have a bare ground wire ran inside the anti static hose from rockler all the way from the dust boot to the dust deputy. Then leaves the inside and grounds the other pipe coming out of the dust deputy then ran to ground on a metal electrical box that is grounded.

I have ground wires ran from my control box on the xxl to all 3 aluminum extrusions one the machine. I have good ground to my spindle and the spindle is externally grounded as well.

Anyone have any ideas?

The community has some notes on this sort of thing at:

If that doesn’t help, let us know what you’ve done at and we’ll do our best to work through this with you.

Wow, I just finished my upgrade to the 2.2kw spindle and we have pretty much the same setup, including the extensive grounding of the hardware. I used an emergency stop box as the main switch and ran the ground from it to a single ground bar that ties in all the non-powered grounds. The powered grounds are tied to the same ground point through the plug ground pins. VFD/spindle grounds are tied to the power system ground.

See if you can get all your grounds tied to a single point. For me, all go to the 110v ground wire. I’ve not experienced disconnects yet, but past performance is no guarantee.

Hi @quicky06,

I remember the other thread so I suppose you already actually measured the continuity values between the different parts you grounded ?

@LiamN has a great thread and video going over the subtleties of grounding, which boils down to star-grounding everything (as @runnin8 mentioned) but also hunting down the areas where you can actually get a good electrical contact for those ground wires, which is not everywhere, and may not even be exactly the same between different machines.


Yes I have between .2-1.0 ohms from all my grounds to the ground bar on my panel.

Now that I think of it I am still relying on the ground through the board for the machine ground. I’ll run a ground to bypass the board tonight when I get home.

None of my grounds go to existing hardware on the machine. I found that to be problematic. I cleaned a location and drilled and mounted a ground straight the extrusions.


From what I recall from the other thread you did a pretty thorough job, cabinet grounded etc.

It’s worth trying the bypass ground to the machine chassis as a test but I would not want to leave it there as it will create a ground loop with the Shapeoko controller’s ground.

Given everything you’ve done I’m most confused as to what is left, other than doing unlikely things like getting a length of metal rod and driving it into the ground yourself to get a solid ground connection.


This is why I posted. I’m stumped. I’ve got a power filter on the vfd feed. Not the router feed. I also have not put a usb isolator on the computer to c3d cable because I was told the current boards already have them.

A week or two ago when I had a disconnect I didn’t have ground on the spindle. Pulled the connector and inspected and put back together. And I had a ground. I’m going to check pin fit there tonight.

Also what I think is happening is the dust hose is hitting the stepper behind the x axis when it happens but not sure. I need to get some static built up and see what I can get to act up.

Liam’s point about driving a metal rod into the ground sounds extreme, but worth thinking through. Not sure of your shop’s overall wiring at all, but it is possible that you’ve wired everything to a ground that actually isn’t very grounded.

Might be worth a plug-in power filter to feed the Shapeoko power brick and the computer?

That should be quite easy to check, use a multimeter between one of the bolts holding the shapeoko controller covering on and the screen of the USB connector, if there’s no connection then I would say it’s likely one of the isolated units, or @Julien might remember the chip designation.

If that’s intermittent you could try adding a ground strap straight to the spindle as a debug measure, wrap onto one of the water connectors or similar?

Well, if there is static building up on the hose then that would be a double confusion, you’ve got a bare ground wire inside it and the hose is supposed to be anti-static, as it’s Rockler we should probably believe that too.

1 Like

My 2.4d board has this isolator near the USB chip:

1 Like

I’ll check tonight.

As far as my static build up comment I have another vac system in the shop that’s not grounded that I could use to test the machines grounds. Wasn’t talking about known static in the hose. I’ve actually never been shocked by static in any of my systems including my 2 hp dust collector.

It’s summer in Saint Louis and humidity is not lacking.

There is one thing you could ground it all to…

Grounding post


It’s about 29 miles away. Might be a little far lol.

As far as my grounding situation.

I have a sub panel on my enclosure that handles all power. There is a 50 amp 220v 4 prong connector it plugs into, this then runs through 6 awg wire to my main panel which is 12 feet away. Ground rod is out side on the other side of the wall. Not a lot involved.

1 Like

Well sounds like you’re pretty well grounded, assuming the ground rod is making a good connection. Presumably it doesn’t look corroded, the connection fixings on it are tight etc. ?

I’m going to go through it all tonight after work. I don’t get home for a 6+ more hours

Depending how brave you are feeling, you could try to wire one of these into your VAC/Control board

I’m running some testing on a custom non C3D electronics setup that was getting random hard triggers. It was made worse through super dry weather a few weeks ago. I since wired one of these into the main controller electronics and the issues disappeared.

For £10 it might be worth a go as it seems allot of these issues can be traced back to your buildings circuit.


Got home today walked in the door to my wife freaking out. Apparently she missed a couple of emails from Etsy from orders for a week ago so I’ve been spending my night cutting out orders hoping I can get 5 hours of sleep. Doesn’t look promising. Will mess with this tomorrow night hopefully.

I had a night of cutting acrylic, which I think is the worst I’ve encountered from the stick to anything standpoint. Still no issues, but then, I’m on the Gulf Coast.

Interestingly, before running last night I did a thorough ground continuity check and was surprised that the X and Z motors were not grounded, even though the spindle was, and all are hanging on the HDZ. Evidently, the standoffs are enough to break the ground. Not sure why, but I ran jumpers to the from the drag chain mount bolt to motor mount bolts and that did the trick. You might want to check if your X motor housing is grounded or not.

As an aside, my poor touch plate has multiple gouges from the clip slipping off, or my forgetting to attach it. I forgot last night, and was reaching for the panic shut off when the bit made contact and actually closed the loop through the touch plate to the control board. I
guess that’s a fortunate by product of the way I grounded the system. But, I think I’ll still try and maintain the discipline of using the clip… at least until I cut with larger shank bits.


1 Like

Interesting, just re-checked mine and both motors are grounded, however, there’s no threads in the motors so it would be very easy for the anodised surface of the motor to not contact the bolts or standoffs. Giving the motor face a bit of a scrape or using an anti-vibration washer would probably fix this.

My spindle also does this for me, I think it’s because mine has cheap steel bearings not ceramic but anyway, all the bits are grounded by the spindle which has saved me that mistake a few times.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.