Grounding your Shapeoko

Why would you want to ground your Shapeoko?

This isn’t something everybody should do, but if you have either of the following issues, you should consider it;

  • Dust & chip accumulation (on rails and V wheels causing movement problems)
  • Random disconnects (when cutting plastics or when extraction is on)

There’s nothing ‘wrong’ with the way the Shapeoko is delivered and there’s no safety issue WRT grounding on the machines (if you add a VFD spindle that must be properly grounded but that’s not for this thread). In most cases you won’t have a grounding problem and don’t need to do anything, what’s below should allow anyone who thinks they might have an issue to be confident that it’s resolved.

This isn’t discussing grounding to deal with EMI from routers or VFD spindles but these measures won’t hurt that either.

Here’s a video showing the process, it’s the same content as the remainder of this post.

What’s the Problem?

There are a range of factors, materials such as plastics, cutting in a low humidity environment and the use of dust extraction can all build up static electricity on and around the machine. The simplest way to deal with this is to ground (or earth) the machine so that it can’t develop a static charge.

If static builds up on the machine then it can cause dust and chips to stick aggressively to parts of the machine such as the rails the V wheels run on, dust hose etc. and cause problems. Discharge of this static can also interfere with the electronics, the stepper motors, whilst not grounded, provide an attractive path back to ground via the controller for static charge once it builds up sufficiently.

Carbide3D did a pretty good job with the power supply and controller on the Shapeoko. The power supply passes mains earth through to the 0V of the controller, which is connected to the big heatsink on the back via the mounting bolts and through that to the left Y rail (XL and XXL, more on the regular Shapeoko late). Notably though, the screen of the USB connection is isolated.

We might think that this would ground the whole machine, but despite being mostly big lumps of metal, there’s a couple of problems with this.

  • The power coating on the steel parts is pretty-solid and an electrical insulator so in many places despite being bolted together metal parts have no electrical connection
  • The V-Wheels the machine moves on are plastic which isolates parts from each other

This means that despite most of the base frame being grounded the X rail and Z carriage are floating and able to collect static charge (Y and Z for regular Shapeoko).

Some of the Polyurethane drive belts (Gates) are anti-static and would provide a discharge path between the major components but this is not true for all of the belt vendors, and there are still places where the machine can be electrically isolated.

What we have

The Left Y rail is grounded by the controller on my machine. When tested, nothing on the X rail, or Z carriage had ground continuity (with the spindle connector removed). It’s well worth checking that the bolts holding the steel frames to the Y rails have broken through the power coat and that the grounding gets through to the Right Y rail.

The basic machine circuit looks like this;

AC power feeds the Shapeoko power brick, your computer and the router installed in the machine. Utility earth is fed through the Shapeoko power supply to the machine controller as 0V and this grounds the machine. The router is likely double insulated and does not have any ground connection.

The USB connection has an isolator which disconnects it from the controller ground to reduce the risk of ground loop based interference and disconnects.

If you have a VFD-driven spindle things are different, your spindle needs the case to have a good earth for safety. You probably have a noise filter in line with your VFD and then a screened cable from the VFD to the spindle carrying the 3 phase power and the ground connection to the motor. As this is clamped in the Z carriage as a side effect this grounds the Z carriage as well.

How to fix it?

We are NOT going to mess with the grounding / double insulating on the router / spindle.

Fixing the grounding is pretty easy, we just need to supply ground to the X axis , the Z carriage if you have a regular router and the extract hose if you have an extraction boot with an antistatic hose.

As we are just grounding for static we don’t need low resistance ground connections but we should still follow sensible practice and star ground our system anyway.

If you have the regular size Shapeoko, instead of having the controller on the Y rail and drag chains to route the cabling up to the X and Z axes, your controller is probably attached to the back of the X rail instead. This means that instead of the base and Y rails being grounded by the controller it’s the X axis that is grounded and the base and Y rails are floating. For the rest of this I’ll be referring to the XXL so if you have the regular Shapeoko swap over the X and Y instructions for your machine.

Thanks to Julien for pointing out that the regular Shapeoko doesn’t have drag chains and the controller is on the X beam

What about the scary ground loop?

Ground loops aren’t scary, they’re well understood and they’re easily avoided in this case.

We want to add ground connections to the Z carriage, X axis rail and the extraction hose. As we’re just draining static charge away we can use 1Meg Ohm resistors in series with each connection, this mitigates the effect of any ground loops even if things do get cross-connected. You can either solder one resistor into each ground wire or use an anti-static plugs with built in 1M resistances.

If you have a VFD driven spindle then you’ll only need to ground the extraction hose and the X rail;

A non-star example of how not to do grounding;

The idea of star grounding is that we choose one common point as the ground for our system and we individually route all the ground connections back to this point. As an example of how not to do it, here we’ve got the Computer, the Shapeoko, and the router on daisy-chained extension cords from one outlet and we’re taking our additional ground from another outlet. The Z carriage is grounded back to the Y rails and the extract hose is daisy chain grounded off the X rail. This is how you get ground loops and interference problems.

Wiring

Pull some ‘hook up wire’ through the main Y rail drag chain. These should be long enough to go down to your earthing point and one needs to go through the other drag chain to the Z carriage.

Crimp a ring connector onto the short wire and attach it under the retaining nut on the drag chain bracket, or under a screw directly attached to the X axis beam.

That’s the X beam grounded, now check for continuity to both Y rail plates.

Feed the extraction hose ground wire through the X rail drag chain and up to the Z carriage, route it over the top and attach a connector onto the end, I used a bullet connector, it doesn’t matter what connector. Attach the mating connector half to the wire in your antistatic dust hose . You can now ground the dust hose when you attach it to the machine.

Ground the other ends to your chosen earth point, a resistive plug, the ground in your VFD switch box etc. use the 1M resistors unless you don’t want to.

The stock Z axis

I still have the old stock belt driven Z in a box. On this sample the V wheels tried to isolate the moving Z plate, this attempt was thwarted by the springs and possibly by the belt if you have an anti-static one fitted. Unfortunately, the powder coat has joined the fray. On my Z axis I found that it was insulating one of the aluminium rails that the router plate rides on, given that those are one of the worst places to have chips and dust sticking you may need to scrape off some powder coat until you get a clean connection. The carrier plate for the Z limit switch, some other bolts, and the belt pulleys were also isolated.

You should also check whether the router bracket is electrically connected to the Z plate.

The least bad place I could find to ground the std Z was under the locking nut on one of the bolts the springs attach to, this is threaded into the plate and therefore has a reasonable connection.

Testing

Now test the grounding.

Use a multimeter, with the Shapeoko plugged in but not powered up, attach one side to ground (the croc clip of the bitzero works for this) and work your way around, the first two should be close to 0 ohms to ground;

  • Both Y rails, the bolt heads on the steel plates are good test points
  • If you have a VFD spindle check that’s grounded too

The resistance to ground of the rest will depend on what value resistors you used;

  • Both Y plates, again bolt heads are good
  • The X rail, any bolt that’s threaded into it
  • The Z carriage, both parts, the sliding X and the bit that goes up and down
  • The metal wire in the antistatic hose
16 Likes

Bookmarked for focused read later.
Thanks for this @LiamN!

5 Likes

If it’s useful, it’s because I’m standing on the shoulders of those who thought and modded before :wink:

3 Likes

Ditto this looks very interesting indeed

Question for @LiamN

I had some disconnects that were related to my dust extraction hose. I could even feel the static shock when I touched the hose. So what I did was wrap a copper wire (insulation removed) around the outside of the hose. Not the entire hose, but at least a 2ft section. I attached a (ground) wire to the copper wire and ran that wire to the ground (3rd prong) on an extension cord.

It’s the white wire in these photos…


… this solved my disconnects, but now I can get to my question. In your diagram the extract hose connects to a box with the label “1M Ohm”. Should I have added a 1 Ohm resister to this white/ground wire between the copper coil (wrapped around the hose) and the ground plug/prong on the extension cord?

1 Like

Great, and for different people different aspects of the grounding are going to be the issue or solution, the dust hose is by far the most likely I think and using antistatic or grounding parts through the dust collection system is good practice anyway.

I wouldn’t worry about it no.

The main reason for the 1,000,000 Ohm resistor is to minimise the effect of any ground loop should one grounded part come into contact with another, e.g. the steel wire in an antistatic hose touching the grounded spindle or Z carriage. If you get a ground loop it can cause electrical noise issues, most don’t but easier to avoid from the start. This resistance is high enough to make any current flow tiny but static charge is low current flow (unless it’s lightning :wink: ) so it will leak away through the resistor.

All that said, I didn’t use the resistors because my spindle already has a low-impedance ground and I’m happy that I can spot and diagnose a ground loop issue if one occurs.

5 Likes

So, I’ve completed a 3+ hours of toolpath job on some plastic I had lying around in the shed. It’s a horror to work with, the static is so bad it jams up the dust vent on my table saw every time I cut it.

Shapeoko was fine :wink:

A few chips got flung out and stuck to the X and Y rail, but they fell off as soon as I touched them, no static cling, the extract hose stayed clear and clean the whole time.

It is with some irony that I must admit, the static problem was on the clear PVC curtain of my dust boot which built up a layer about 1/2" thick very quickly, perhaps I should figure out how to ground it. :man_facepalming:

5 Likes

Hi. Thanks for writing these and doing the video would my earthing point be back to the controller?

1 Like

Hi,

NP, hope they’re useful to people.

For the earthing point I would suggest taking the ground from the power that feeds the controller, if you have an extension cord, for example, which the Shapeoko, router etc. are plugged into, take the ground from there.

You can use something like this if you don’t want to do mains wiring;

Does that help?

1 Like

I think so. Let me know if I go off course here.

I have a dedicated main lines I put in. I have a multi-plug / surge protector plugged into the mains. I would have controller, router and pc plugged into multi-plug. I would then run the additional ground wires per your video and then bring them all back to the multi-plug and terminate there with the nifty plug you shared from Amazon?

Thanks again!

1 Like

Yep,

That’s the idea of star grounding, you pick the common ground point and everything comes back to there. So in your case above, the multi-plug would be your star ground point where everything comes together.

If you get electrical noise problems you might end up putting the router on a noise filter plug or another outlet.

Awesome thanks. I do currently have the router on another outlet so I will keep it there. I just tested the grounds. I don’t even get a ground to the left X rail or the frame. Only the controller itself. Guess I got some work to do.

When checking the ground to the aluminium and steel parts remember the coating is non-conductive. To check the main X and Y rails I found the bolts screwed into them were best.

I have a newer low profile controller mount which does not use the aluminum chunk behind it so it appears ground is not getting the to the left x rail nor leaving the controller at all.

1 Like

Now that is interesting, the frame grounding through the controller appeared to be a design decision.