Neither Work nor Machine Positions active after GRBL 1.1 Update

Just updated GRBL to 1.1. With thanks to @WillAdams I was able to reset the GRBL settings to match my XXL.

I use Universal Gcode Sender. I’ve downloaded the latest version 2.0 but have not installed it yet. Therefore, I’m still using the old version 1.09.

Most things seem to be working as normal. However, none of the X, Y or Z Home or Work Positions are functioning. They sit at 0,0,0 regardless of any movement.

I have a couple less important questions, but they can wait until this issue is solved.


Time to move on from UGS, at least the old version. It’s not compatible with 1.1
Try CNCjs.

Hey Neil,

Thanks for the quick reply. I’m not familiar with CNCjs. I just checked out GitHub to read up on it and I see the download link. But by “web based” in you note I’m assuming I have to be online to use it???

My shop is detached from the house so I don’t have Internet access while using my machine.

As I said in my note, I have downloaded but not installed V2.0 UGS. Guess I should give it a try???

Thanks again for your help.


Nope… That turns a lot of people away. There is a version that can be run on a raspberry pi over a network (I think that’s what originally made it popular). The version for Windows is a regular, offline application.
Just download the exe on the site I linked above.

Will do.

Thanks again.

You need to run CM at least once to set up the eeprom settings again (just like the instructions say…). Latest nightly UGS works fine with 1.1.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.