New controller, testing before going on, GRBL port issues

I received my order of a second controller this afternoon, and just shut my SO3XXL down, pulled the plugs from my existing CMB and insert them in the new CMB (both v2.4d) to test it before continuing with the project I bought it for, and on starting Carbide Motion and clicking connect I get the following:

Cannot Open Port for cutter
GRBL Error: Serial Port: Not Open Error
GRBL Error: Serial Port: Device Not Found Error
then back to the connect screen, and back though the above if I initiate a connection…

Windows audibly recognizes when I plug in or un-plug the usb cable.
with the power off, manually Moving any of the steppers makes the right lights go on.

The Steppers make the appropriate buzzing when the power is turned on.

I plugged in the original board(both are v2.4d) and everything runs as it should…

I plugged it in to test it before flashing it for EstlCAM.

Other than not finding the USB port, and what comes next, everything I tested has the same responses from one board to the other.

Maybe this board was not flashed for GRBL and Carbide Motion is simply not finding the port setup in the firmware? I did specify that I would be flashing it for ESTLCam when I ordered it, but there were no notes with it. Ideas, suspensions, etc…

Just a guess, you’re using windows 10 ??? I’ve read in here of people having problems when updated their windows automatically, maybe it was flashed with the newest C3D version which seems to me to have been the culprit since Bill Gates won’t allow himself to be blamed. Can you verify what grbl version or CC CM version I meen, see I really don’t know just guessing and trying to help. Search for the newest C3D programs and problems. New board makes sence they sent it with the newest program… Good Luck… more reasons I like the other program… Jude ps this topic - 100 posts

1 Like

Maybe look at the solder connection of the usb connection on the new board??

1 Like

If you think it is the new C3D program and want to reflash it, here’s a dangerous thought…can you connect the 1st board (the one that works) flash to estlcam and that restore the controller but switch the wiring so that the 2nd board gets unflashed with the other board’s working settings??? That’s the reason you wanted two controllers. right? Probably a bad idea but it is late at night and I turned on the forum out of habit.

1 Like

The new board will use a different com port than your previous board.

Try re-flashing?


Uninstall / reinstall CM and the driver?

1 Like

Thanks Guys!
This is all on the RCA Camrio Windows 10 Tablet I just bought, and just to verify the new Carbide Motion Board (CMB) has no issues before I get into uncharted territiroy flashing with ESTL.and wiring for environment swapping.
CHecked the solder Ray , looks like it was vat soldered-uniform wickup, clean, clear, bright, and shiny! Thanks!

I’ll try easy first.

  1. RnR carbide Motion and plug it into the now board…all I am trying to do is verify it works before I flash it to Estl. Thanks Will,
  2. Flash the board with GRBL and try Carbide Motion again. Thanks Craig.
  3. [quote=“grumpa, post:4, topic:5874”]
    can you connect the 1st board (the one that works) flash to estlcam and that restore the controller but switch the wiring so that the 2nd board gets unflashed with the other board’s working settings
    [/quote] Jude,
    I thought about that too…and that will likely be step three-if 1 and 2 don’t sew it up!

I thought making the boards copies of each other would make for the easiest transition since I would have a proven original setup to fall back to…

I love it what a plan comes together! Thanks guys (Finally, an appropriate time to say-well, type-that…)


yeah, that’s what I thought I was thinking when I thought I was thinking, at least it wasn’t a dream. Glad you understood where I was pointing although the pointing was more like" ohh no look out" , Alternative plans require alternative efforts which hopefully are based on realistic actions. Dual controllers are definitely alternatives but not like “alternative medicine” which isn’t medicine at all. If you understand what you want for an outcome than you should be able to accomplish it. Good Luck and waiting for your success. Jude

1 Like

Does your Device Manager list the board when connected?

I had connection issues with my 2 board controller box as they were hubbed and my Estlcam controller was COM3 (GRBL was COM4). Carbide Motion always connected to COM3 first. This required I disconnect Estl/COM3, then restart Carbide Motion. I renumbered COM4 to COM1 and it’s been working correctly ever since.

Moral of the story, I believe Carbide Motion attaches to the first “Shapeoko” COM instance in numerical order. While I haven’t tried to spoof it with other USB COM ports, there’s no way to spec your controller address in Carbide Motion.

As @WillAdams side, re-installing Carbide Motion might wipe whatever setup files are instantiated and maintained by the app.


Didn’t think of that though that is part of the reason I wanted a dedicated computer as I have had that same issue before with other virtual port assignments-and shuffling connections…Thanks Jim! I will check that first before I do anything else-as it will give me more of an idea what is and is not happening.

:thinking:I have been there…several times, usually right after someone sneaks in my shop and replaces everything with exact replicas…like this morning…


Those gremlins used to work for bill gates, now they have nothing to do, not really their fault, just what they do…

1 Like

I am afraid the “someone” that replaced all of my shop equipment with exact replicas also bathed and fed the gremlins after midnight…they seem to be getting meaner and multiplying!

Original board happily setup on com3 working like a champ…
New board is forced into com 4 where it wont talk…

upon plugging in the new controller I Removed Carbide Motion, then a complete boot, then a reinstall still gets me the same GRBL Errors above,

Plugging in the original board at this point, with out rebooting everything works like a champ!

That leads me to believe the new board may not have firmware on it. Windows acknowledges the new board audibly when it is plugged in or out, and tries to put in on com 4.
Manually rotating any stepper the the power off makes the right lights light up-just as it does on the original board. I don’t think the firmware has any involvement with windows seeing the circuitry, but it does have to do with what windows does with it-but then I know how to spell GRBL and not much else about it…!

Just to be sure I don’t create more issues I will email all of this to Tech support and get their guidance.

1 Like

I finished my prototype toy and the hot water line UNDER the house broke last night, got the stuff to fix it and bypass the broken line, tried to go outside and the doorknob broke, inside the knob, the bar that pulls the bolt broke inside the end of the bolt so after destroying the entire knob the bolt was still stuck in the jamb with no how to grab it, got it loose after prying the door jamb out of wack to reach the end of the bolt. Gremlins abounding, they didn’t go out for dinner, they came over here, please call them back. Anyways the final tweeks are completed to the prototype and the first production run will start as soon as I can catch up to the gremlins, have traps set for them tonite.I’m misspellign cuz ny lens just fell out of my gulasses. Good luck, we both need it. Jude


There’s a likely chance it was not flashed based on the fact you acquired it for reflashing and non-GRBL applications… I"d see if you can reflash it straight away with Estlcam as you intend.



I lost yesterday evening to replacing the mailbox and post after my son ran over them w/ the car.


That was my first thought…But immediately behind it was "Verify the board works as inteneded first once you know it does, then customize it… Easiest way to make a problem that you don’t understand worse, add complexity! I would rather ask and look stupid than not ask and have to pay for the proof of being stupid!

Today I will be flashing the new board, with any luck I’ll be flashing it twice, once with GRBL and once with EstlCAM! Then it is just the waiting game for the parts to make assemble everything.

1 Like

No official advise, just encouragement and good luck, it’s a big task and I hope for your success. Jude

Hot water line complete, gremlins chased off, sent them running south, close all gremlins gates…now I can return to my shapeoko workshop this afternoon… What was I working on though???