New Shapeoko HDM Spindle not turning on

Hi everyone,

Brand new machine. I went to run my first job and I don’t believe the spindle is turning on. I stopped it just before it plunged into the material.

I then tried to run the spindle while in jog mode and nothing.

Strange thing - I remember the red light on the spindle lockout being nice and bright as I was setting up the machine - and now there is no light from the button no matter the pushed position. I suspect I am having the same problems others have had with the spindle not turning on.

Tempted to open up the buttons etc and test connectivity but I am waiting for further instruction from service.

I suppose using the jog feature is the best way to test the spindle? Open to ther ideas to trouble shoot I am a CNC newbie.

What post processor and what gcode sender? Carbide motion’s spindle jog will not start the spindle as it sends a macro for the machine to run that is lower then the default set minimum rpm. If your spindle lockout is not illuminated regardless of position then your problem is in the switch, the wire or the vfd control board most likley. Have you moved the control box around at all since you first tested the machine? Spindle control board problems are definitely a thing and seemingly the most common point of concern for people looking for help here. If you havnt yet, the support email is very fast to respond.


Hi Rob,

I am using Carbide 3D Shapeoko post processor. I am unsure of what you mean by gcode sender (carbide motion?).

I am chatting with service and I will post my message below as to the troubleshooting:

This morning I powered up the VFD, then machine, iniitialzed with carbide motion. Machine moved home, had me inser ta cutter, and it measured it on the bitsetter and then parked itself at the front center. I hit jog on the VFD and got a 20RPM spin. I then pressed the spindle lockout button and hit jog - and I still got the same 20RPM spin. (still no red light on the lockout button in either position)

Right now I am the MDI and I have tried:
m3s10000 command with the spindle lockout in both positions and I get nothing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.