New Shapeoko XXL - X-Axis not moving at all


I’ve just finished assembling my brand new XXL, and I’m now trying to jog and run the Hello World gcode. While the motion seems to be jogging alright in Y and Z, X is not moving at all. When I press the X jog buttons in Carbide Motion, I do hear a noise around the gantry (what I assume is the motor?), but there is no movement happening.

Incidentally, I notice that though I’m able to move all of the axes manually (by physically pushing with my hand) when the motion is off, the Y and Z axes have locked with the machine on. This is not the case with X - I am still able to slide tool holder along the gantry.

Thoughts, suggestions, tips? The belt tension seems to be the same for the X as it is for the Y, and I’ve tried both tightening and loosening the V-wheels to no effect.

Separately, I think (and perhaps this needs a new topic): I’ve found the tensions of V-wheels and manipulation of eccentric nuts to be really confusing overall. Are there any good guides with pictures to this online?


Please check the set screws on the X-axis motor pulley.

Please see:

for more on the eccentric wheels and V-rail.

1 Like

Thank you - that worked.

Now it looks like the X-axis belt is leaning pretty considerably, though it is as straight as can be, given the position of the wheels. Is this normal? How can I adjust for this?

Turn the pulley around. The build instructions actually show this pulley facing both ways, so it depends on which version of the instructions and which picture you look at, but I have seen it both ways. Turn the pulley so the tooth side is closest to the motor and the belt will line up correctly. I installed mine like yours and eventually the belt wore prematurely.


Thank you! Excellent advice - I think I’m all set.

I checked the latest build guide, and it only shows it with the teeth on the motor side. So at least the instructions are improving. But I wish they would send the instructions with the kit.

Agreed- I mean, the Z and X-axis motors arrived completely assembled, so it wasn’t intuitive that I would need to disassemble, flip, and then reassemble something - I appreciate the help!

I’m having the same problem as @taltalim I thought my X-Axis was fine when I jogged it using carbide motion. I stuck the router in and now it stutters, or sticks, sometimes the motor just sits there spinning and not moving the belt.

I can easily move the x-axis by hand (even when the machine is on, but Y is hard to move when on?), but can’t seem to get it to move +x or -x, or if it moves it gets stuck after a couple mm move.

I’ve tried loosening and tightening the belts but nothing seems to help.

I tried to view the instructions posted by @WillAdams but it went over my head. Can someone dumb it down a bit for me? I’m more of a software guy.

This was all pretty new to me too. I think you just need to tighten the set screws on the motor - they’re the tiny screws in the little holes that you can see in the image above on the shaft of the motor (the little hole next to the belt). Do an image search for set screws if you’re still having trouble.

1 Like

Yeah. I guess we need to bring the troubleshooting instructions up to speed w/ this brave new world of pre-assembled components.

This thread has some images which may be helpful:

If you have trouble getting the machine to move, then likely the problem is with the eccentric wheels — they’re likely too tight. Please release the belts, loosen the eccentrics completely, then gradually tighten them as described in the link at: Shapeoko CNC Router, Rigid, Accurate, Reliable, and Affordable

Thanks! I’ll give both of these a shot when I get home.