New Version of CNCjs 1.9.21

I see a new version of CNCjs was released yesterday.

I have installed it - and it seems to be working OK. I had already updated my OS with
sudo apt-get update
sudo apt-get upgrade

and then went on to update CNCjs with
sudo npm install -g cncjs@latest --unsafe-perm

However, there were several Warnings - which I have attempted to deal with (by going to the websites of the various author’s involved) - but most of them far exceed my understanding of Linux (Raspbian) to work out successfully - some of them in turn also have their own dependencies which make this quite a rabbit hole for me since I don’t have a deep enough understanding.

If anyone also upgrades AND knows how to deal with, and eliminate, these warnings then please let me know the steps. Right now I trust that they are not critically important :slight_smile: since CNCjs still works!

Below are the messages I get (6 WARNINGS) :-

pi@raspberrypi:~ $ sudo npm install -g cncjs@latest --unsafe-perm

npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated popper.js@1.16.1: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1

/usr/bin/cncjs -> /usr/lib/node_modules/cncjs/bin/cncjs
/usr/bin/cnc -> /usr/lib/node_modules/cncjs/bin/cnc

@serialport/bindings@2.0.8 install /usr/lib/node_modules/cncjs/node_modules/@serialport/bindings
prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild

prebuild-install WARN install No prebuilt binaries found (target=10.19.0 runtime=node arch=arm libc= platform=linux)
make: Entering directory ‘/usr/lib/node_modules/cncjs/node_modules/@serialport/bindings/build’
CXX(target) Release/obj.target/bindings/src/serialport.o
CXX(target) Release/obj.target/bindings/src/serialport_unix.o
CXX(target) Release/obj.target/bindings/src/poller.o
CXX(target) Release/obj.target/bindings/src/serialport_linux.o
SOLINK_MODULE(target) Release/obj.target/bindings.node
COPY Release/bindings.node
make: Leaving directory ‘/usr/lib/node_modules/cncjs/node_modules/@serialport/bindings/build’

core-js@2.6.11 postinstall /usr/lib/node_modules/cncjs/node_modules/core-js
node -e “try{require(’./postinstall’)}catch(e){}”

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon:

https://opencollective.com/core-js
https://www.patreon.com/zloirock

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)

styled-components@3.4.10 postinstall /usr/lib/node_modules/cncjs/node_modules/styled-components
node ./scripts/postinstall.js || exit 0

Use styled-components at work? Consider supporting our development efforts at opencollective.com/styled-components

cncjs@1.9.21 postinstall /usr/lib/node_modules/cncjs
opencollective postinstall

                       Thanks for installing cncjs 
             Please consider donating to our open collective
                    to help us maintain this package.

                        Number of contributors: 32
                           Number of backers: 4
                           Annual budget: $409
                          Current balance: $280

          Donate: https://opencollective.com/cncjs/donate

npm WARN react-i18next@10.7.0 requires a peer of react@>= 16.8.0 but none is installed. You must install peer dependencies yourself.
npm WARN react-datepicker@1.5.0 requires a peer of react@^16.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN react-datepicker@1.5.0 requires a peer of react-dom@^16.0.0 but none is installed. You must install peer dependencies yourself.

  • cncjs@1.9.21
    added 86 packages from 54 contributors, removed 187 packages, updated 143 packages and moved 2 packages in 308.079s
    pi@raspberrypi:~ $

I have not installed that version of CNCjs yet, but honestly none of those warnings matter, you’re prone to get those when using such a rich library framework as Node.js, where people update things daily.

1 Like

Yeah - I thought as much. Just being anal - you know how that is :slight_smile:

1 Like