New version of Lightburn with Sainsmart laser

I am in need of an assist, I figure many heads are better than one. I decided to add a SainSmart laser to my XXL. It went smooth, soldered in a 4 pin header to the 2.4 GRBL board. Ran wires and connected everything up. Watched Myers Woodshop video on configuring Lightburn and followed the steps. That all seemed to go great as well right down to the setting of my origin. Used the fire button and the laser fired at low power with no issues. Pulled in a simple image and clicked start. This is where things go wrong, The laser does not fire when I click start, the gantry moves as expected. I can see on the Shapeoka GRBL board that the signal led is lighting like the laser should be firing. Yet nothing from the laser.

I do not understand why if the fire button is working, why is the laser not firing during a cut? Any suggestions would be greatly appreciated, I am so close to burning some wood I can smell the smoke. Lol

What do you have in that setting?

I believe the default is 256, but when using the PWM signal from our Shapeokos, the PWM value is usually used to drive spindle speed, so it scales from 0 to the value you have set in $30 GRBL parameter.

I have my $30 set to 24000, which is the max RPM of my spindle, so I adjusted “S-value max” to 24000 in light burn such that I don’t have to change this setting when I switch between milling and lasering).

If you have the default Carbide3D’s $30 set to 1000, and you left the S-value max to 256, lightburn would generate intensity values that max out at 256, which would translate to a max of ~25% duty cycle (1000/256) on the PWM. Since you are probably not running at 100% power setting but more like say 30%, that would reduce the value further, and it’s possible that the laser is actually on, but at such a low power that you don’t see it.

This being said, the manual “Fire laser” button at X% should give a similar result, so if you see it, I may be completely wrong.

1 Like

Having made the exact mistake Julien refers to (setting S value max to 255 when my $30 was 1000), I will say that the first indicator of this is how large of a percentage you have to use in order to get the “fire” button to show a visible laser. In my case, a 4.2W J-Tech, it was 10% in those faulty conditions (after I fixed it by setting S-Max to 1000, 3%). However, 10% was visible, so my regular jobs more or less worked - they were just at 1/4-ish the power I expected.

So yeah - what is your $30, what is your S value max, and how high do you have to crank the percentage on the fire button?

1 Like

I wanted to come back and let everyone know that I was able to finally get this to work. Here is the odd thing, the connector at the Shapeoko board was backward. This does not make sense to me though, Why would the fire button in move turn on the laser but when starting a job it would not? When I flipped the connector around it started working as expected. I feel as though it should not have worked at all, I do not have the brainpower to sit and figure that conundrum out. For now, it works great and I am already burning my first piece.

I did have all the settings you reference correct and I would like to tell you how grateful I am that you and @RickT took the time to try and help me out. This has been a crazy run of weeks for me as my day job is in education and we have been trying to get all our students set up on distance learning. I am sure it has been a struggle for most, but trying to get this little guy running was a bit frustrating.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.