New XXL build can't get past homing setup, backwards Y

I have to first state I am a complete newbie to CNC. After completing my build today I followed everything from “Finished”. Tried setting the homing and the x and z seem good but the Y moves the machine forward and I have to shut it off before it crashes into the frame in the front.

I read everything I could on this set up and in the last 3 hours and have made zero progress, it still goes to the front right and not the rear right were the stop switch is. I know this is probably a simple fix but I can not seem to find the answer.

I have read and seen post on changing the settings in grbl but have no idea how to do that in Carbide motion. Any help here would be greatly appreciated.

I had the same issue. If you reverse the y axis stepper motors on the control board it should fix it.


@baaja is correct that swapping the motor connections at the board will reverse this.

The other ways to do it:

  • swap a pair (leftmost or rightmost) of wires on each motor
  • reverse all the wires on both motors
  • change the Grbl invert bit

to do the latter:

  • connect to the machine
  • bring up the log window (tap l)
  • bring up the MDI window (tap m or click the button)
  • send $$ to the machine
  • the settings will appear in the log window
  • look up the invert bits setting:
  • assuming the default of 6 invert Y by subtracting 2 so
  • set $3=4 and send that (if $3=0 above, then set $3=4)


Well that was a simple fix. Thank you so much!

Thanks for this info. This is the kind of stuff that really moves the learning curve in the right direction.