NEWB Goin NUTZ! X = Y & Y= X

Just finished putting together my XL. Wow - who said 1 hour! :unamused:

My problem - when I use Carbide Motion and use the jog buttons if I click on movement in the X axis the carriage moves in the Y access.

I thought I had marked them correctly, but even when I swap the connectors it doesn’t help.

However, I was not so smart to mark the Y1 and Y2…

What to do?!

You have them swapped around. You might have swapped the X and the other Y.

Tried that, makes no difference.


Then chase them all the way back to the servos and check. Failing that, you’ve got some seriously weird setup programmed into GRBL. Maybe @WillAdams will have a better idea.

1 Like

I just found this and it’s totally different from other instructions.

So do the limit switches connect at the left of the board or at the right?


Right side. Labeled X limit, etc, if i remember.

Here is a link to a pic will uploaded,this should help.

Who knows Mike. There are different versions of the instructions.

This version doesn’t even cover the limit switches.

As I put it together i had the presence of mind to test all the limit switches with a continuity tester and they all work fine. And I marked them all appropriately. And they are plugged in in the order shown and in the same place as in your image.

So that’s all right. Surely they do not affect the normal operation of the machine?

Thanks for trying to help me.

This is what happens when I run the Homing routine.

Thanks, Les

Please check that the X and Y homing switches can be reliably triggered by the machine when it is being moved — some folks have found it necessary to add shims to ensure that the switch is the first thing which contacts anything, I swapped my X-axis switch to the opposite side of the plate so as to avoid hitting the belt anchor, for the Y-axis switch I added some washers to the standoff to adjust the positioning.

Also see if swapping the X and the Y axis homing connectors corrects things — it’s easy to get them swapped.

Check and see if the control board has 3 separate lights for the homing switches — if so, they’re labeled and you can verify which is which in that way.

Is your router power cord getting in the way, and preventing the homing switches connecting? Mine does every now and then (Reminder to me: I REALLY need to zip-tie it out of the way!). Failing that, are you 100% sure that your homing switches are actually making contact (and depressing) at the end of their travel?

1 Like

Your limit switch lights are likely locate as circled in this photo (as we’ve both newly built our machines). You can manually test each switch with a finger and see if the matching light lights up. Of course, you’ll need a helping hand or clever work with a mirror.

My guess is one of them won’t light up and the wiring needs trouble shot. If they do, then I’d check that they are not getting pressed by the machine for some reason. Perhaps take close-up views of the switch when the limit should be reached and post back?

On a side note, are these limit switch lights broken out? - They’d be handy in a control panel at the front of the machine, but I don’t know if my soldering skills are up to snuff…

Also, in testing my machines switches, I found that my z-axis switch seems broken and wobbles back-and-forth and not just moves in and out like the other two do - I will follow up with support.

Also - Hey! Mine didn’t have the cool Shapeoko text engraved on any of the rails! Now I’m jealous!

1 Like

I could not see the Z-axis home and it always starts there, then it homes x & y. Your gantry and carriage movements are correct. This is a limit switch failure, limit switch mis-connection, carraige blockage, or controller board fault as described by those above.

It would be nice if Carbide Motion had a diagnostic or inidicator that toggled when the limit switches were active? I also think you can derive a limit switch is operational by pre-pressing one and then starting a homing operation.

Let us know how this pans out…


Thanks for all the tips. I did check the lights. Two burn bright but the one is very dim. So it might be the switch.

I ended up using an app that ran GBR (?) Called Universal-CNC-Controller. I downloaded the Shapeoko logo file and did the Sharpie trick and it did fine.

Going to look at it all in the morning with a fresh brain!

I appreciate the community help.


Definitely sounds switch related. The other sender doesn’t complete the homing cycle I assume.

You could turn off homing in CM and grbl by changing the CM setting and sending $22=0. A temporary fix to keep things moving till you get the switch figured out.

1 Like

One thing to try is to leave the gantry in the middle of the table somewhere, then manually click the switches and see the lights on the control board light. Don’t bother with the homing yet. They should all be about the same brightness, and the right light should light up for each one. If one of them is particularly dim, could be a bad connection in the connector, or the switch is bad - I’ve had a little trouble with them not working until clicked a few times.

1 Like