No jog button on carbide motion

Just got my machine built. Started to do the initial setup per the manual. I have downloaded and installed CM 4.0.431, the machine is XXL and my computer is Win 10.

First Issue - the manual says to connect the power supply and USB cable. Turn on the red inline switch. The power supply green light will light up indicating power to the supply brick and a blue light can be seen through the slits in the control box indicating power to the board. The Red switch does not have any indication which way is on or off. No matter which way I switch the rocker switch there is a blue light on in the control box.

Second issue - When I open carbide motion the only Tabs I can select are Run, MDI, and Settings. I go to the settings and select Shapeoko 3 XXL and bitsetter. It ask if I want to use the current X,Y location. I have to chose Yes as I have no way to jog the machine. After I click on “send configuration data” I get a count down to 0 and the screen is the same. Still no Jog tab and no Home tab. If I click on run I get “load file” or “initialize machine”. If I click on “initialize machine” The X axis moves about 4" left, stops, and I get a homing error.

What am I not doing right or catching in the initial set up? Shouldn’t I have a Jog button to move the machine with even if it is not initialized? I loaded a .nc file into the run portion but still no jog tab to zero the machine.Thanks for any help. i hate to get this far into this and can’t even move the gantry or zero the machine.

Did you watch the Carbide Motion training videos?

No. Where are the video’s located? I found guilds, How to’s but no video’s. I did find some on you tube with Winston Moe but I don’t think I have found one for carbide motion set up.

A couple of things to help you along here:

  1. Written Guide:
  2. The blue light (which you can see through the controller enclosure) will stay on for a few seconds after you powder down the supply while the capacitors dissipate.
  3. The inline switch may not be red (they have varied from batch to batch) - but will definitely have one side which has a bump on the one side. Pushing the bumped side down will turn on the power.
  4. The machine needs to be initialized (homed) prior to jogging - and by has to that means literally the jog option will not be present until you initialize the machine.
  5. Don’t toggle the bitsetter function until you have jogged the machine over to where the bitsetter is setup.
  6. See the bitsetter guide here (page 15):

Hope that helps,

1 Like

Hi Craig,

Sounds like there is a issue with your limit switches. Either a input is seen on the controller for one of the 3 switches when it’s not expected, or oposite.

Check that the switch for X axis is connected to X input and so on for all 3 switches.
With the machine off, move all axis to their limit switch and verify that they make contact and that the switches close upon contact.

Your machine needs to be initialized before the run and jog tab becomes available.

I would have deselected the bitsetter until you have successfully initialized the machine, then you will be able to give accurate coordinates to the bitsetter.

Edit. Well I didn’t expect Mr Shapeoko himself to send a reply at the same time as me, so sorry for the double post :pray::grin:


I have gone back and looked at all the connections. They are where they are supposed to be. While I had the controller cover off I also disconnected the touch probe and bitsetter from the board.

I have checked the limit switches again and confirmed again that they are mounted correctly, and make contact when the axis are moved to the back right limits.

The button does have the bump on it. Thank you for that. However the switch does not do anything. With the bump down or up the blue light stays Lit on the board and I can still connect the machine through CM. The way I read the user guide if the switch was off, CM would not be able to connect.

When I do an initialization, the X axis only moves left. Should it not be moving right? After about 4-8" it stops and I get two errors. Homing failed, and Limit switch not found. If it is looking for the limit switch moving left it is never going to find it.

Thanks for all the replies and help.

That was a good clue! If only the X is moving, then I believe you have your motors plugged in incorrectly. Homing routing goes: Z-Axis, Then the X and Y start searching!

Double check you don’t have the X and Z motors swapped on the board.




The X,Y,Z where all plugged in the board correctly. It was at the harness that I had plugged the X & Z in backwards. Once I got them corrected the machine homed Z, X and Y. The Jog Tab became available and I can jog the machine. It also remembered it was an XXL which it had not done so far. Again, thank you all for you assistance. Craig


You are very welcome! Glad you’re up and running.

Case Closed.