No limit switches in Carbide Store

 My S-3 X-axis limit switch just quit on me. Did all the s/w reinstall and troubleshooting and nothing worked. At home the system just sits and chatters on X-axis so am assuming the switch is dead.
 I checked in the Carbide Store and those were not listed. Does anyone have a good source for the miniature limit switches?

Hmmm! Just read another post about limit switches and the lights on them. Forgot about those and went back to check on mine. All three show lights, but still the same problem with getting an error message that a limit switch had been hit and stopped homing and started chattering again.

Contact support…they have always been fantastic helping me when mine went.

1 Like

Very sorry to hear about this difficulty.

Please check the switches per:

If that doesn’t help, let us know at and we’ll do our best to help.

1 Like

Talk to Luke Here on this site or at his web site for his proximity switch upgrade. More accurate and more reliable.

THANKS! I went to the site here and also accessed the Web Site for the new Z-asix harfware.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.