No power to router via bitrunner! help!

Soooo…let me set the scene for ya…

Im working on a project. After i secure my MDF on my wasteboard, i go ahead and initialize my machine via CM. After i install my bit and set my zero using the vintage Bitzero V1, (works like a dream), i load my project into CM, press start and the machine to do its thang!

After my S3 XL measured the bit using the installed Bitsetter V1, the machine took the bit to the starting point and started to plunge into the MDF.

When the router started to plunge, my Bitrunner DID NOT power on my router nor did i hear the usual audible ‘CLICK’ that lets me know that the Bitrunner sent power to the router. I stopped then program immediately and tried to troubleshoot the issue. My first thought was to check the router for power so i checked the power switch on the router, the button with the red ring (it was on) and the power to the machine. I also plugged the router into direct power and it worked fine.

I had just completed a project a couple days prior to this happeningnso i have no idea whats going on.

Stupid question perhaps but is the BitRunner enabled in CM? Did you upgrade CM and forget to check that box maybe?

Don’t remember which version has it, one has a fuse in it you might be able to check and replace.

1 Like

Thanks @CullenS for replying!

It just worked a couple days prior and i didnt update CM since but ill make sure.

@Zman ill check that today and let you know

I had a similar issue on my S4 once. Ended up being a broken connection on the plug for bitrunner on the control board. Was pretty loose when I first installed the bitrunner plug but overtime, it got a bit worse. Ended up pulling the control board out and desoldering the connector and then soldered jumper wires from the plug header pins to the board. Now I have a pigtail hanging out of the control box and plug in that way. It’s been working well so far.

1 Like

Check if the BitRunner led changed color. If it did and the router did not turn on check the brushes of the router. Often the router brushes wear out. On the Makita/C3d Router the spring that pushes the brush to the armature of the motor gets restricted in how far it can push by the wire that connects the brush to the router controller. When the brush wears enough the wire is tight and will not let the brush make good contact with the armature. The Makita/C3D routers seem to need their brushes changed on a regular basis. Additionally when the brush gets shorter some people experience disconnects caused by electrical noise that the short brushes introduce to the system.

If the BitRunner did not change led color the router will not come on. In that case troubleshoot the wiring and if you have enabled the BitRunner in CM. You stated that it worked before so the CM configuration is not likely the problem but check it any way. Also on the top of the BitRunner are 3 switch positions. Make sure you are in auto.

An additional test is if the led is on and switch is set to auto then change switch to on and the router should come on. If the router does not come on check the brushes first and the router switch is turned on, and secondly the wiring.

1 Like

So, i took apart my Bitrunner and the fuse was not blown. As a matter of fact, @gdon_2003 , i dont have the Bitrunner with the switch on it like that. Mine looks newer.

But after looking at the motherboard and connections and all that, @UngerCNC i think this maybe what youre talking about.


This is what my board looks like


This is the connection thats loose…


Heres a close up of that connection

Where can i get a new board?

You can contact support@carbide3d.com and they can help you get a new board. The last time I got one it was about $150.00.

1 Like

You can kind of see what I did with mine here. If you can solder halfway decent, you could very well do the same thing I did. Much cheaper than buying a new board.

If you don’t feel up to the task, I can certainly help you out. Just ship your control board to me and I can get it fixed in a day or 2 and send it back to you. Just pay for shipping both ways.

3 Likes

@UngerCNC , thanks brother. I can solder pretty good assuming it’s like welding lol seriously thanks for the offer and the insight.

I appreciate you @CullenS , @Zman , and @gdon_2003.

You guys are amazing!!!