Nomad not responding on USB bus

I just opened a support case for this but was wondering if anybody else has already seen this problem.

I haven’t used my Nomad in a while and today when I tried to cut something, the machine didn’t respond via the USB connection. Carbide Motion can’t find it, and the macOS System Information app doesn’t show it on the USB bus.

When I power it on I can hear the motors spinning up etc., so I don’t think the power is the problem.

Is the controller board dead? The machine was not touched/used/moved/anything since it worked successfully a few months ago.

We have a basic tech doc on this:

To expand on that, things to try:

If that doesn’t work, new board is most straight-forward.

Huh, it just started working again out of nowhere. All I did was launch the Hex Uploader app in order to try to reflash the firmware. I clicked the serial port popup menu and saw that the machine was there, and then I tried Carbide Motion again and it could see the machine without problems.

1 Like