Nomad Postprocessor for PhotoVCarve, Cut2D, and VCarvePro

Hi Mechanical Goose!

Darren and I are setting up for a few tests before we try out the post processor. If things go easily we will have a post within a day or two, if not, a few more days. We’ll have a formal Vectric post processor for the Nomad - no compromises.

I’ve owned and used the Vectric packages (I eventually outgrew them) but I can tell you they are some of the easiest to use and capable 2/2.5D CNC programs around.

MeshCAM and Cut3D are essentially the same thing so no need to buy Cut3D when you have a Carbide3D.

Links to discussion of those here:

Specifically see a custom post-processor at:

Thanks Will! Didn’t know about that one. Let me check it out and report back.

That post Will pointed to is Shapeoko specific and doesn’t manage the spindle (i.e. on/off, RPMs) nor tool changes. It doesn’t use some of the newer capabilities of the version 7.5 and 8 codes.

The one I’m working on does manage the spindle and tool changes. Otherwise the one Will mentioned is remarkably similar to mine - no surprise - GRBL is GRBL.

We’re testing now. Darren is providing feedback as quickly as he can. I hope to post the post shortly along with a testing procedure for Nomad users. Later we can extend to Shapeoko.

1 Like

While mbellon is working on a nomad specific post processor, I have been experimenting with existing pp’s in cut2d and found one that works.

It’s the Xcarve processor. In fact, I was using this as the machine option when I was creating cut files on easel.

It’s yet to be seen if it cuts all in one direction (so not switch between climb and conventional, which Easel was doing) but I did a quick air cut and it seemed to be working fine.

Of course I can’t wait to get my hands on a nomad specific pp, but it looks like this will work in a pinch for me.

An update - I just ran a successful cut on my nomad using Vetric Cut2d with the XCarve post processor. In fact, the cut took 27 minutes; when I was using the Easel post file, the cut took 47 minutes. So the code is much more efficient coming out of Vetric than it was coming out of Easel.

I was also able to put tabs exactly where I wanted them. With Easel, I wasn’t able to choose where the tabs went, only their length and thickness. Easel put tabs in bad places (like right on curves!) So Vetric has made finishing a whole lot quicker as well.

I’m excited for @mbellon to develop a nomad specific post processor! Can’t wait to see how awesome it is :smile:

The testing is going well. We’ve resolved all anomalies and Darren is testing. I’m awaiting his sign off before posting.

The post enables tool changes, spindle speed changes, and spindle on/off… a little bit more than other things out there. It uses the circle capabilities of the Nomad (G02/03).

It works with the versions 8.0 release but should be fine with the older version 7.5 release. It handles VCarvePro and Cut2D. There is no need for Cut3D as anyone with a Carbide3D has MeshCAM.

Aspire will need to be tested separately by a brave individual. It should work…

PhotoVCarve requires a modified post, one derived from the one for VCarvePro/Cut3D to remove all references to arcs and circles. Apparently PhotoVCarve is in a world unto it’s own.


SUCCESS! Much thanks should go to the Darren and MechanicalGoose.

1 Like

There are two Vectric post processors for the Nomad 883 and Nomad 883 Pro.

They should be treated with some suspicion until we get additional feedback that others are satisfied with them. Be sure to run air passes and keep your hand near the E-Stop the first few times a job is run.

Carbide3D-Nomad-Inch.pp - For VCarvePro and Cut2D
Carbide3D-Nomad-PhotoVCarve-Inch.pp - For PhotoVCarve only

Millimeter versions can be created by editing the files, changing the G20 to a G21 and saving the file under a new name.

Don’t buy or use Cut3D - use MeshCAM!

I can’t seem to attach them to this message and I don’t have any WEB accessible storage so I have to figure out how to make them universally accessible. Until then, message me with your private email and I can send them to you.

We could post them to the Shapeoko wiki — e-mail me at

Thanks Will! Will do.

@mbellon I haven’t had a chance to run test cuts yet with your post processor, but I will do one soon… but awesome news that there is proof it works!! Awesome :smile:

Posted: (608 Bytes) (566 Bytes)

1 Like

Awesome as usual Will! Thanks!

I hope others find them useful.

I recently purchased the Cut2D program and downloaded the post processor mentioned in this post for the NomadPro. After I saved my toolpath in Cut2D, I tried to load it into Carbide Motion but I received the following message:

Error in line 1: Syntax Error %.

Unfortunately, I am not G-Code literate, does that mean I should remove the %? I have attached the G-Code. Thank you!

Male Inlay (1.3 MB)

The first line of this file is


which ought to indicate a comment.

I suspect that Carbide Motion is getting confused by it being the first line and not having any further content — was this file saved with a name? Is there any metadata which you can apply w/in the file which would then be filled in w/in that file?

Thank you for your response William. I added: (FILENAME: INLAY.NC) under the % and I received the same error. I will try to save something different in CUT2D and see what happens.

Weird. Try deleting the line?

Deleting it may fix it as Will says. I was able to open it directly without deleting it in UGS so seems its something perhaps specific to CM.

Thank you both for your help. Deleting the % did the trick! You were right Will :slight_smile: