Nomad Pro 883 Will Not Home - Hangs

Followed the sequence of steps for startup listed in the FAQ. Nomad 883 connects using Carbide Motion, and will throw error if the machine is not connected. When I try to jog the unit, it directs me to the homing screen, which then proceeds to do nothing.

I moved the motors to the center to prevent them from hitting limit switches as others have suggested. I hear all the motors lock, the light comes on. Tried rebooting. Tried powering the machine up and down. All I get is a screen that says “Homing Machine” - do I need to go through the sequence of reloading the firmware as described in the FAQ? Is that the same firmware as used for the 883 pro?

I recommend calling and emailing C3D and asking for help.


More information - I got it to work on the Mac - no fiddling around, but I really need it to work on the PC in the office, Any possible settings for the PC that I am missing?

Sorry, Mac user here.


Hey Jake,
I recommend re-installing the newest Carbide Motion for your PC again.
You can also try the previous version of Carbide Motion.

I’m having the same issue with first generation Nomad 883, Windows 7, and the latest Carbide Motion update. Any ideas?