Nomad slow Z movement

Hey guys, I finally got back my Nomad Pro back from support and really enjoying the machine again. I recently purchased a 100w laser engraver and since that machine needs a windows platform, I bought a cheap HP laptop for $220 from Bestbuy. 4 gigs of ram should be plenty. I wanted to use it both for Carbide stuff and the laser but the first time I jogged CM with the windows computer boy was it slow. Especially when doing rapid positioning. It’s like grandma crossing the street. I hooked my Mac back up just to verify the speed since it has been a few weeks. Yup the jog on the Mac is a lot faster.

Anyways my question…

I am not sure if this is normal or not but I could have sworn the process was faster. I created my Gcode in Carbide Create. When I open in CM and Home -> set zero -> then begin the cut, the Z comes down very slow to the stock. It starts very high then comes down very slow. From what I remembered, it should know how high my stock is and hover just a bit over it for positioning, turn on the cutter then goes down. In my case, it starts very high then slowly comes down. Is there an option for this somewhere in CC?


Second question, in Carbide Create, when I select the tools, the depth of cut is always red and 0000’s. I was hoping it would auto populate based on material. Is there a glitch or is that how it is suppose to be? I had to uncheck Automatic and entered a number manually.