Not so random disconnects back

I had the disconnect issue a few years ago and solved it with a ground wire.

Today trying to mill aluminum it cuts for 10 seconds and disconnects. If I restart the job it goes as far as it did before plus 10-15 seconds of milling before disconnect. It seems touching the metal for a short period is causing the disconnect.

Humidity and heat in the shop was very high (85+ F and 80% RH). Wondering if people have seen this with high humidity?

Everything else is the same. Tried the normal (different cables, air cut successful, different USB port etc…)

I had random disconnects because I think my usb port on the controller is flaky. So I put a wire tie holder about 3 inches from the controller and wire tied the usb cable in place so that vibration or movement of the Shapeoko did not cause physical disconnection of my usb.
wire_tie_holder

2 Likes

As far as I know (read), this is quite the opposite, very low humidity seems to induce more static issues, it’s even been recommended to spray a mist of water on the stock to reduce the likelihood of disconnects in those situations.

Do you have a trim router, if so check its brushes ? I remember @WillAdams mentioning that sudden disconnects after a long period where everything is fine, can be due to brushes wearout

Next-up I would try either isolating or connecting the stock to ground to see if it changes anything. The good news (…) is that your problem seems to be repeatable easily, so there’s hope to pinpoint the source of disconnects quickly.

2 Likes

Tried another bunch of stuff today. No progress.

Checked the brushes, they are in great shape. Less than 30 hours on this Makita.

I upgraded carbide motion.

I was using easel, but generated a new gcode file with carbide create as an additional test.

I grounded the stock directly to the chassis.

I air cut with spindle on and off. Both successful.

I wiggled the USB cable during the job, def not the cause. I changed the spindle rpm too to make sure vibration wasn’t the issue.

I’m going to try a different pc as my next test. After that I’ll try a job in wood (though I suspect that will be successful since the air cuts work).

Are you using a desktop or laptop PC?

It might be worth trying a laptop running on battery (no mains adapter connected).

It’s a laptop. I’ll try that too.

Other things that might be worth checking (if you didn’t already)

  • does the outlet / extension cord for the Shapeoko have a good ground connection?
  • is the router plugged into the same outlet / cord? If so try running it on it’s own cord from an outlet some distance away
  • try grounding the Z axis (or is that the ground cord you ran previously?)
  • do you have a voltmeter? If so, spin up the router and test for DC or AC volts between the router and the workpiece / Shapeoko chassis
2 Likes

I ran the job on another laptop with no AC power without issue. Then I decided to blow the dust out of the other laptop. I ran the job on the old one without the AC adapter, again no issue. Took the ground wire off the stock, plugged the laptop in and the job ran fine again.

No conclusive evidence, buy maybe dust was contributing to it somehow.

Have you tried a usb isolator? That solved my issues.

This is the one I got. SMAKN USB Isolator USB Digital Isolator Isolation USB to USB Industrial Isolator https://www.amazon.com/dp/B00XXPO4UG/ref=cm_sw_r_cp_tai_Od.-EbM96BXB7

2 Likes

If I remember correctly, carbide said this would not solve my problem since I have a newer version of the controller. I think the idolaters helped older revisions that lacked a couple capacitors.

1 Like

Yep, mine also has the isolated USB, daisy chaining USB isolators is more likely to hurt than help.

2 Likes