Not sure where to post this

Hey all,

Work kept me busy this past week so I didn’t have time to use my Shapeoko 3 until today.

A week ago I used it for a simple carving and it worked great. Today I wanted to carve
something to be framed. Set up my material and homed (Used Create and Motion for this project) the machine. Set the start point, loaded the gcode and clicked the run button. The machine responded but didn’t ask for a tool change which I thought was strange as it always has in the past. At this point the machine drives the router back to the home position then slams and jumps the belts as it didn’t stop there. I shut off the machine and rechecked everything.

Started it back up, rehomed it then tried to set the start point. Clicking on the y axis worked then I clicked on the x axis but the machine responded by moving along the y axis again. Any axis I clicked caused movement along the y axis only.

So, I powered everything down, unplugged the power at the control board, while that was draining I tested all of the limit switches with an ohm meter and they all tested very similar, there was 0 resistance when they were not depressed and a completed circuit when the were pressed closed.

I uninstalled and reinstalled CM, used another cable from my pc to the control board, plugged the machine back in and went through the steps to start a new project. This time the router left the start point I selected and moved about dead center of the waste board which was a long way from where I wanted it to start.

Restarted everything again and ran the CC Hello World code and the machine repeated itself by moving to the center of the waste board.

Sorry to be so long winded!

Anyone have any ideas?

Thanks all.

By any chance did you set your origin in the middle in CC and put the zero in the corner for CM?


Very sorry to hear about this difficulty.

We have a page on troubleshooting machine functionality at:

Are you using Carbide Motion 3 or 4?

If 4, does the machine complete homing correctly?

If using Carbide Motion 3 is this a new or old machine? If an old machine do you know if it has Grbl 0.9 or 1.1 installed? If it is a new machine or an old one with Grbl 1.1 then you shouldn’t use Carbide Motion 3 — it only works with Grbl 0.9 — please switch to Carbide Motion 4 and send the machine configuration per:

If you continue to have difficulty please let us know step-by-step:

  • what you did
  • what you expected
  • what actually happened

Thank you for the replies.

Luc, I have so far always used the lower left corner as my start point in CC so it’s kind of become second nature to follow that tradition. I thought of that too, that’s one of the reasons I tried the “Hello World” code.

I had a look at the links you provided Will and did two additional things to my machine, I reset the board via the little white buttons and I then sent the machine config which one or both have seemed to make a positive difference.

I have had the machine about a month or so and I “think” it’s grbl ver. 1.1, I am using the latest CC and CM. The machine seems to have no difficulty homing and has done so correctly every time that I’ve ever asked it to.

I have to be honest, I haven’t had nearly enough time to learn so I’m not sure if this next part of this post is how it’s supposed to be or not. In the photos, the black dot represents my selected start points and the measurement I took (in inches) represents the distance the router travelled to its actual start position. I made that test nc file to check out the operation after resetting the board and sending the config to it. Running this file the machine appears to behaving correctly other then the possibility of the difference between my selected start and the machines actual start locations.

Again, many thanks!

If you’re having difficulties after homing please review:

If you’re using CM4 then it will only contact with Grbl 1.1

If you continue to have difficulty, please let us know step-by-step what you are doing and we’ll do our best to help you puzzle things out.

Can you share the nc file?

Thanks Will, hopefully I’ll figure it all out soon.

neilferreri, here’s that little nc file. (13.5 KB)

The origin is at the lower left as you can see here:

It moves to the beginning of the cut:


It then moves down from safety height:


and begins cutting

1 Like

Guess who has Camotics now!

I guess what I’m missing is what if I needed to place that cut in a very specific area on the work piece. Say the design is 4" sq and I wanted to center it inside of an existing design, this is what I need to research and figure out, how to place my cuts exactly where I want them on my work piece.

Thanks for your patience and help Will!


If it is an existing design that is already made, you can use the center as the origin but…

Centering your work piece could be an issue. You can use the rapid position to place the router in the middle and set this as a repeatable placement. Now you have to align the middle of the work piece with the placement of middle of the router bit. It may in some cases more difficult to hold down and place. If you are using tape and glue, it could be hard to aim properly and if using wasteboard tie downs, they may not be in the right place. Your work piece must also be parallel with the X and Y axis and establishing a reference in the middle may also be a bit more tricky.

You may have to experiment a bit.


That makes sense Luc, thank you, I’ll be keeping at it!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.