Opening Files In UGCS

I’ve been having trouble opening NC files created in Carbide Create in Universal Gcode Sender. I made pretty much the same file in Easel, Carbide Create, and Fusion 360. The files made in Easel and Fusion 360 open no problem, but the file from Carbide Create won’t open. This is my first time using Universal Gcode sender, so I thought it might just be that file, and tried files that I’ve previously made to only have the same problem. I had a YouTube subscriber ask to show how to export Gcode from Carbide Create to Universal Gcode Sender, and I’m guessing they are having similar problems. If anyone can help please let me know

What’s the file extension? Change it to .nc

It is .nc I don’t think Carbide Create let’s to export in any other format

I don’t use Carbide create, but I thought it exported .ngc or something. They’re all just text files. Can you share the file? (I can’t take a look… Away from computers for a week, but that will help the next guy)

Carbide KWS (643.3 KB)

Hi Kody,

FYI it opens just fine in UGS on my computer (Windows laptop)

even though your file seems to have Mac-style line endings.

On the PC you are running UGS on, can you open the file in a text editor and see its text content correctly?


I’m running windows 7 pro for and os and it opens nothing. I can open the text file and it looks fine to me, just like any carbide create file i’ve used before in candle, but UGS reads NO code that I’ve exported from carbide create

Mysterious indeed. To try and troubleshoot what’s going on, you could check if UGS spits out any specific error message on the command line when you try to load the file. From a command shell, you can use the “–console new” option, it will open a separate console window, which will happen to contain all traces that UGS makes behind the scenes:

C:\Users\Julien\Desktop\ugsplatform\bin>ugsplatform64.exe --console new

Here’s what the output of launching UGS then opening your file produces, on my computer :

Loading LocalizingService…
Loading JogService…
Loading ActionService…
Loading MacroService…
Loading SendStatusLineService…
Loading SettingsChangedNotificationService…
Loading WindowTitleUpdaterService…
Services loaded!
Setting UGP version title.
Initializing firmware… …
Object bounds: X (-34.522, 34.522)
Y (-34.522, 34.522)
Z (-0.762, 10.0)
Center = (0.0, 0.0, 4.619)
Num Line Segments :44841
Object bounds: X (-34.522, 34.522)
Y (-34.522, 34.522)
Z (-0.762, 10.0)
Center = (0.0, 0.0, 4.619)
Num Line Segments :44841
NUM ROWS: 44878

There is a (small?) chance that you could see a meaningful error message there

The other possibility is to file a bug report on the UGS forum, attaching the file, mentionning the version of Windows + UGS you are using ? But since I can open it, most likely others will too, so I suspect this is lead nowhere.

Have you tried changing the extension from .nc to .gcode?

I tried this with no different out come. Sorry for the late reply I’ve been busy the last few days

Here is a video I was doing when I had the issue I have the link set to when I’m using UGS

Looking at that video:

  • you could (should?) try upgrading to the latest UGS release and retry, July 2017 was a long time ago.
  • you could check the traces usign the procedure I mentionned above (open a Windows command prompt, navigate to where your UGS executable is, and run ugsplatform64.exe --console new). I would not be surprised if there was a strange error message showing up complaining about something in the file, and we could go from there. Just a shot in the dark.

To reinforce what @Julien says, use the version at . the UGS site that is the “nightly” version. It’s actually the most recent release from December, they haven’t actually fixed their nightly builds.