Overshooting y-axis at the start of run

Just started using the shapeoko for sharpie test runs. I run the homing cycle and it proceeds smoothly to the upper right corner. I set it to zero at the bottom left of the material, then run the code.

The “spindle” moves up all the way to the top most part of the y-axis in a way that it seems to think there should be more space up there. It hits the top part with a loud bump, and the motors make a sound like they are trying to go further up. It then proceeds to do the job, but the y-axis is now misaligned starting the job lower in the y-axis than it’s supposed to(probably because it thinks it moved up the y-axis more than it physically really did.

Am I missing something?

There are a couple of things which tend to cause this sort of problem:

  • excessively high retract height — in Carbide Motion this is set at: Job Setup (gear icon) | Machine | Retract Height
  • not getting zero set properly — usually this is a mis-match caused by having the origin set to stock bottom in the file (Job Setup (gear icon) | Stock Thickness | Bottom) but zeroing on the top of the stock — EDIT: the other culprit is zeroing at center of stock when job is set to bottom left corner

If it’s not these things, please post a sample file, and a step-by-step description of how you set up and process a file and we’ll help you puzzle it out.

When you say “up” the y axis do you mean towards the back of the machine? A couple of times I’ve had something similar happen and discovered one of the cables in the way of allowing the y axis limit switch to be hit.

"excessively high retract height —"
This refers to Z-axis right? Will check again in case the noise is made by the Z-axis and not the y. What is a good retract height value?

"not getting zero set properly " - I am using a sharpie, should I set stock thickness and origin at 0?

"When you say “up” the y axis do you mean towards the back of the machine? " -Yes. limit switch seems to work fine because the homing cycle works fine.

So you homed it successfully then jogged the machine to the lower left of the work piece then zeroed all but when you tried to run the file it headed back on the y axis instead of starting to draw with the sharpie right away?

1 Like


I don’t think Carbide Create will accept a zero value for stock thickness.

Yes, you should zero out at the origin relative to the stock to match what you’ve set in the file.

Please see:

Yes that is exactly right. It’s not supposed to do that? From run, it goes from zero, then moves back to the tip of the Y-axis (does the grinding thing) then proceeds with the work, albeit on a lower y-axis relatve to zero.

When you did the job set up are you sure you had your work area properly sized and it’s origin in the bottom left corner? Then also set your job origin there? Was the Shapeoko logo or other drawing laid out to fit on your defined work area? Did you tape the piece of paper somewhere near the front of the machine?
It heading back on the y axis, grinding, then starting to draw sounds like the origins are somehow mixed up or not set up properly. It’s trying to get to a place it can’t get to (the grinding) to begin then when the grinding/skipping stops it thinks it’s now in the right position (one you defined?) and begins.

The Hello World worked perfectly fine (no grinding), its when I tried to make my own vector in carbide create and import to carbide motion that the problem occurs (Then again I have not tried to repliciate the Hello World to check if the issue is also applicable then)

"are you sure you had your work area properly sized " - I do this by selecting my Shapeoko Model from the dropdown right?

This might explain a bit more about setting it up. Assuming you’re using a piece of paper for your stock size/job piece.


Thanks for taking the time. This was the way I did it.

Hmmm … if it’s all set up properly in CC then when you’re in CM and have jogged to the lower left of your work piece and zeroed there when you load and run the gcode file it should start within the stock size area you set up. If it’s heading all the way back on the y axis something else must be wrong. Is it set up in inches?

Its in mm, with the corresponding mm values. So normally it should start milling form zero to the first point? hmmm Wonder what makes it head back up the y?

Please post everything:

  • .c2d file
  • generated G-Code

and a step-by-step description of how you:

  • set up the stock
  • clamped
  • homed
  • set origin
  • zeroed

For each step describe:

  • what you did
  • what you expected
  • what actually happened