PhotoVcarve and Shapeoko Pro

So I bought PhotoVcarve, loaded a picture into it, watched their video (the training vid), and selected g code inches, and after initializing machine and setting zero, and starting the project, it produce a 1/8"x1/8" square just barley past the surface. What the @#$% am I doing wrong?

Are you selecting the post-processor for Carbide 3D machines?

I wrote a bit about setting up Vectric software at:

There wasnt a carbide3d specific post processor that I saw so I chose the g code (in)

can you upload the generated gcode file you ran ?

Please try looking under “Shapeoko”:

C:\ProgramData\Vectric\VCarve Desktop\V10.5\PostP\Shapeoko_mm_TC.pp
C:\ProgramData\Vectric\VCarve Desktop\V10.5\PostP\Shapeoko_mm.pp

(adjust the application/version to match the program you are using)

candb3.tap (554.7 KB)

That gcode does not include a command that sets the unit (G20 for inches or G21 for mm), and GRBL happens to be in mm mode by default, so when you run that file, it interprets the X/Y/Z values as mm rather than inches (hence the minuscule engraving).

You need to install a Shapeoko-compatible post-processor like Will mentioned.

(in the meantime, to confirm this is it you can edit the tap file and insert a G20 command at the top of the file, and it should work too)

1 Like
  1. How do i edit the tap file
  2. where can i find the .pp for…nvm scratch that I found the one from neilferreri · GitHub but how do i put that into the pp folder of phtovcarve

also I aint a moron but there’s a reason I changed my degree from info systems to a BA in history, lol me and coding do not get along.

You can edit the tap file in any text editor available on your operating system. But really, to not have to mess with the generated gcode file, it will be better to just install the post-processor: you should be able to just copy/paste the Shapeoko_mm_TC.pp and Shapeoko_inch_TC.pp files into the “PostP” directory of VCarve (following the directory path Will mentioned above), and restart PhotoVCarve. They should now show up in the list of available post-processors when generating the gcode.

1 Like

ok so im trying and i can only copy/paste the code not the file.
here is the folder that the PP are in:

ok yall i might have gotten this figured out. i had to download visual studio code to drop the hard code into, then had to figure out the file extension (its pearl) then finally saved then into the correct folder…here goes nothing…again i hate messing with code…lmao

nope didnt fix it. i restarted Photovcarve and it still doesnt show the pp. i’ve changed the security settings on the files and the folder but to no avail.???

I did not quite understand what you did. Did you manage to copy Neil’s .pp files inside the PostP folder?

the only way of saving it was to put it into visual studio code and saving it. no way to save code into a folder

If I havent said this yet, thank you a whole lot. It still isnt working so i guess ill call support on monday. kinda sucks to spend $149 on software that aint worth #$&%


Stick with it, Vectric software is very good - even if it does have a few foibles such as where to put the PP files and what their purpose is.

thanks AndyC i aint got a choice spent the money on it to open up a unique design capability thats gonna hopefully (if i can get it to work) make me some money