Playing w/ USB over IP

My older K2 CNC router was small enough that I had room on the same work table for a notebook which I used to steer it. The Shapeoko 3, at over twice the size, took all that room.

So I tried running my notebook on a sort of adjacent workbench. It was okay but I didn’t like having a cable draped across the floor (I have a dog, and I can be klutzy). Also, it resulted in a rather long USB cable (we all know about that).

So I took a Lenovo Tiny (a cigar-box sized computer) and put in on a shelf near the Shapeoko and used RDP to access the Tiny. It allowed me to shorten the USB cable to 6’, and worked okay.

But that Tiny machine isn’t mine, I ultimately have to turn it over to the rightful owner, and I wasn’t thrilled with the RDP, I really wanted to drive the Shapeoko via my notebook.

So I figured I’d try one of these:

Provided I keep my notebook hardwired to Ethernet, it seems to work pretty darn great (minimal testing involving cutting air so far). Using my notebook on wireless seems to create some communication issues. Frankly that could have something to do with my wireless in the notebook (the 5G spontaneously stopped working a week or two ago and I haven’t had a chance to investigate). It is moot, really, I’d plug the notebook into my network switch when I use the router regardless.

I’ve only done a little cutting of air so far, but it will solve a couple of problems for me: (1) Shorten USB cable further (down to 3’). (2) Allow me to use a variety of computes to drive the Shapeoko (just load the Silex driver and Carbide Motion). (3) Clean-up my install quite a bit. (4) May provide some additional USB isolation (I powered-cycled my router on high speed a bunch of times and didn’t get any disconnects but again my testing hasn’t been exhaustive).

I made a 3.90" square Masonite board which mounts (using two of the rear plate/extrusion screws swapped for flat heads and a couple of M6 spacers) to the back of my Shapeoko, and the Silex is strapped to that board.

Interesting to note that the Silex is nearly exactly the same size as an Apple TV 2nd and 3rd generation, and many of the mounts would likely be compatible. That wouldn’t have worked for my particular install but if anyone else goes down this path, it may be helpful information.

Mounted to back of my SO3:


I’ve found support for these usb/ip boxes to vary a lot. I’m using a kangaroo pc (about the same size) and running cm4 on it. With it running, you don’t need rdp/vnc, you can connect directly to the web interface for cm4 and it works surprisingly well.

I agree that these sorts of devices have a reputation for compatibility issues.

Having tried it a bit more, I’d say maybe Silex is an exception to that rule.

First, when researching my purchase, I came upon a review of a competing product that said something along the line of “oh good grief, just get a Silex DS-510 and be done with it.” Looking at the DS-510 reviews, they were positive except for a guy that couldn’t get it working on El Capitan, and another guy that misunderstood the purpose of the device.

One of the first things I noticed when unpacking is that the product was actually manufactured in Japan.

The built-in web server (for checking status and updating firmware) and the drivers all seem very polished, I have not had any weird crashes or anything.

The company’s website is also very nicely done.

So far, I’m pretty impressed.

On C4 web-access, I might eventually go that way but I’m not ready yet.

1 Like

Sounds like it’s one that actually works! Keep us updated if it holds together for you!