Please don't go home

Hey guys…looking for some help on one issue I seem to keep having with my xxl. so, I turn on the power to the controller, go through the homing sequence and all is good. I rapid position to the current x,y, location (I have index pins so this doesn’t usually change) still all is good. However, then I go to set the Z axis Zero (of course this changes with material thickness) by moving the plate down to the right depth and hit zero. now, If I try any jogging in any other way than using rapid position commands, it just takes off to the Machine home (Back right) usually scraping my material, potentially bending my bit, and smashing any clamps that are in the way…then I hit load, or turn off the power just to stop the choas, and either operation causes me to have to go through the homing sequence again. Now, being someone who knows nothing about coding, is there something written in behind the scenes to make this happen? it seems any time you zero any axis, then try to jog manually, it does this. Is there a way to fix this aside from turning off the homing? I usually just hit z zero+6 and try to get where I need to using the rapid positioning, but, sometimes I want to fine tune where the job starts from. please help.

Could you please break this down step-by-step?

Please note:

  • what you did
  • what you expected to happen
  • what actually happened

Note the exact commands used, and where / how they were applied, as well as which tools were used at each step if you switched anything.

ok, it happens right after I zero the machine.

  • Power on
  • goes through homing sequence
  • jog it over (with arrows on screen) to zero location
  • set zero all or any zeroing
  • Try to jog with arrows on screen, and it becomes possessed.
    it seems rapid position commands are the only ones that work afters it had been zeroed

And besides what Will said…What plate are you moving??

I guess I should say that if I try to adjust the Z axis depth rather than say move the plate. “by moving the plate down to the right depth” = adjusting the spindle height.
what I manted was to zero the x,y, in the bottom left of my material, then move it over to Zero the Z axis because my material was a bit warped in that corner, and I could not get a good read in that corner

How are you setting the zero? for which axis/axes?

Which software are you using? Carbide Motion?

carbide motion, yes.
the x,y, I line up with the corner of my material (that usually doesn’t change)
The Z, I slowly lower the spindle till it’s touching a piece of paper on top of my material, and I can just slide the paper out

What command / which buttons are you using to set the zero?

Just using the on screen options


There are a lot of buttons on the screen. If you want us to help you , we need your assistance is describing in detail answers to our questions.

What version of Carbide Motion are you using? Ver 349 to 364 Please check.

I would add:
Check your zero location in carbide create.
Select TOP of stock.

If you can post a screenshot of your job setup screen it would help.

Maybe we need to read what he is writing a little better! Seems clear to me what he is doing.
I would maybe reinstall carbide motion.

I will take some pictures later. I will also check out what version of carbide motion I am using, but… t he best I can explain it is once the machine is zeroed, if I try to move it any other way than by the rapid position buttons, it just takes off and I get an error message. I am using the arrows on the screen, in the jog tab.

As was suggested to me for a different issue, you might want to try another software package to attempt to isolate the problem. For example, give the same sequence you described a shot with the machine control tab in Universal Gcode Sender.

If you don’t already have it:

(TIP: Make sure and set your baud rate to 115200 before you connect)

If your X/Z carriage still takes off on you, you can at least eliminate Carbide Motion as the culprit.

Thanks John. I will try that as well.

I was having a similar problem where jogging would cause uncontrolled motion after zeroing using the Carbide Motion software. There were two solutions:

  1. Before jogging after a zero, exit the zero-ing screen, enter the jog screen. Then exit the jog screen, then re-enter the jog screen. You should now be able to jog without possession.
  2. Use a different sender program. I use UGS now and it’s great (except for ignoring tool-change commands).
1 Like

That seemed to work! Thanks. If I exited the jog screen, then load the job, went back in to jog menu, no possession. I think that seems silly that it happens anyway, but, good thing you found a fix. Thanks!

No problem! I think this bug has been reported in the past, but it hasn’t been squashed yet.

1 Like

I had a similar problem with the Carbide software after i installed the homing switches. My solution was to use a different g-code sender (many out there, but i installed GRBL-panel). After getting used to it, i find it far more flexible than the carbide software.

I recall a few issues of ‘possession’ when I got my machine and rolled back to a previous version of CM which fixed it. I’ve since been scared to update it…

1 Like