Pocket 1mm creep on each layer

When doing a 100mm square pocket created with CC. 10mm deep, with a 6mm bit a 2mm plunge down. Each layer creeps in one direction by 1mm. The final result is a 100mm by 105 mm pocket with a 1mm staircase at one end.
I have stripped my machine checked the ball screws and rails.
I normally use ugs but I have tested with candle with the same problem.
Has anybody else seen the problem or got any ideas of the cause.
The machine is a self build arduino grbl 1.1e and has run for 2.5 years without this problem. It only started 2 weeks ago

Definitely not a software problem - this is a mechanical problem. The longer side is losing steps as it moves towards the ‘staircase’, then moving the full distance going the other way.


Thanks for that. I will focus on that and give it a good look .

Have you done the ‘magic marker line across stepper shaft and pulley’ test to see if the pulleys are slipping?

If the staircase is parallel to the Y axis then your X is losing steps or slipping, if it’s parallel to the X axis then one or both Y are the problem.

1 Like

The Y is run with 2 ball screws and the flex connector grub screws are tight and show no sign of slipping. I have run square test with laser rather than the spindle and the lines produced are showing the steps but does not show any slippage to one side or the other.

Ah, so you have a ballscrew machine.

Are you hitting the travel limit on the machine by any chance?

No. It is set to run it the middle of the machine well away from the limits.

I am thinking of rewriting the grbl tomorrow on the arduino.

I had this same issue on another machine a month or so ago. Turned out that the problem was the code. It ran the same on two machines. I regenerated the exact tool path and it worked fine. This was in Fusion 360, but could happen I other SW. oh and I tore down tow machines looking for the issues. Lol.

Double checked all hardware. Screws all tight.

I had updated the arduino grbl to 1.1h still had problem.

Tried CC version 5 still had problem.

Updated CC to latest version7, recreated toolpaths everything works perfect. No creep, very strange.
Tried a version 6 job in version 7 had problem.
Looks like version 7 from now on.

Thanks everyone for your help.

1 Like

After alot of work I have identified the problem and you are correct. CC version 7 was a red herring. The connecting parts from the ball screw nuts to the Y crossbar are flexing. It became more evident when I upgraded the stepper motors.

1 Like

Since the issue is mechanical, have you worked out a solution?

If I understand correctly, the problem was present with the old stepper motors and is still present with the new motors? If so, is it worse now?

Sorry for all the questions, I am just trying to get an idea of how you deduced the flexing, so I may learn in case I have similar future diagnostic needs…

The new motors have shown the problem more because the increase of power. It is good to have found the problem and maybe another upgrade of the machine is now required.:man_facepalming:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.