Pocketing (z axis?) consistently off at least 60%?

I apologize in advance if my question is answered elsewhere, or if this is some extremely obvious, self-inflicted user error that I am overlooking. I’m a novice. I haven’t seen this same issue on any other thread, but I appreciate any advice or guidance this community can provide.

I have a Shapeoko XXL pro

I keep running into issues with my cut depth- It is at least 60% too deep on all pocket cuts.
When I create pockets (For a box,) they cut through the bottom of my piece.
I ran some test pockets in a 1.7" deep piece of poplar to see the results-

When I set the max depth to .25" the result is .39" (64% too deep)
Max depth is set to .5", the result is .79" (63% too deep)
Max Depth set to .75", the result is 1.2". (62% too deep)
Finally, if I set it to 1.25, it cuts through the 1.7" piece and into the waste-board approx 1.8" (69% too deep.)

To setup, I measure the bit depth on the bit setter. Then I manually reset 0 to the X, Y, and Z axis to the upper left corner I am working on.

I haven’t noticed any issues with the v cuts I have done, but that is probably due to it only cutting to the depth of the V…

Thanks in advance for your help!

1 Like

Did you configure for an HDZ when you have a Z-Plus Z-axis?

If that’s not it, post your .c2d file and let us know step-by-step how you are securing your stock and setting zero relative to it and managing all tool changes and a photo showing an attempt at cutting still in place on the machine.

1 Like

Thank you so much for your help!

I bought my Shapeoko used off of offerup… I am not sure which setup is on it. Doing research now to find out.
I didn’t configure either during setup, so whichever is default is how mine is set.
Great starting points to check. Thank you! I will let you know if this is the issue.

This is a picture of an HDZ. The HDZ turns in the opposite direction of a Z-Plus. The identifying features are there is a bearing at the bottom of the ball screw that drives the Z up and down.

Here is a Z-Plus. The Z-Plus is identifiable by the leadscrew that runs the Z up and down has no bearing at the bottom. There is a stud with a hole through it that the leadscrew runs through but is not captured by it. The Z-Plus has less steps than an HDZ per MM so that might explain why you are getting too deep of a pocket.

Go through the configuration and select the Shapeoko you have and the Z you have. During the configuration you will be prompted to set the position of your BitSetter.

1 Like

First off, thank you both so much for your help. Sorry that my response has been delayed; life thinks I should have other priorities. I disagree, but here we are.

@gdon_2003 I see similarities to both images you posted, but mine doesn’t exactly match either. I’ve included pictures below.

As far as the other questions posed by @WillAdams, I have been securing my stock using the tape and superglue method. I have created a simple box, and I have included the file below for the bottom section. There are no tool changes required for this section of the box.

1 Box Bottom.c2d (84 KB)

I will try and see if my initial configurations are to blame, but first I have adjusted some projects I am making (taking into account the approx 60% discrepancy in cutting depth) and I don’t want to fix the issues until I have completed the projects.

That looks to be a Pro with a Z-Plus. Let us know what you find out after configuring thus.

1 Like

Be sure to head over to https://my.carbide3d.com to see the training videos we have for new Shapeoko owners.


As @WillAdams said it looks like a Z-Plus. It is definitely not an HDZ because they have a bearing at the bottom. Perhaps the previous owner modified it with the two screws on each side of the leadscrew. Plus there is a cage at the top of the HDZ between the Z motor and the body with a coupler in between.

Let us know if re-configuring fixes your issue.

SUCCESS!! Thank you all SO much.
I finally finished the 7 projects I was in the middle of, so I was able to look at this again. It was completely user error on my part, and once I went in and reconfigured the settings and changed to the z plus, it is working perfectly. I was also able to center the default on my bit setter, which is a large improvement as well. Once again, THANK YOU GUY, ROB, AND WILL!!! This community really is the best.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.