Potential Strike Now My Y axis has Gone Nuts...Ideas?

Had a 15 - 20 vcarve in pine and during the final profile to cut out the part the boom went nuts and ripped through the middle of the piece. I thought I struck only on X before I hit the emergency cutoff but the Y axis is now completely unreliable.

If I try to jog the Y an inch it moves 3 inches. If I ($h) home it the UGS display reads -5 -5 -5 but it looks more like -15 on the Y axis. Movement in Y also seems more “violent” than normal–really shakes the table.

I have tried soft and hard resets. Homed it multiple times. Checked the Y sprockets and they are tight. Checked the front and back Y alignment (back right was never but that hasn’t changed).

Can’t seem to get this problem to go away. If I try to cut the boom is way off in the Y direction and has to be stopped immediately.

No idea what to try. Almost seems like something on the controller is fried(?) This is Sparkfun btw–it doesn’t use the Carbide controller.

Using Vcarve and UGS for tool chain.

Ouch. First of course, please check all the wiring — ensure that nothing has come loose or lost continuity — if that isn’t the case, it sounds like a fried board. Saw your request in the support queue and escalated it there (and sent a brief note).

Pretty sure nothings loose. Everything functions its just erratic.

At this point it is pretty clearly the Y channel blowing out on the board. If I swap X&Y wires the problem behavior moves to the X axis. It actually jumps from one side to the other on the X beam in two mouse clicks using UGS 1-inch.

Attached is a picture of the Vcarve that was about 95% done before "the incident"


I feel your pain John.


Heartbreaking… such a nice piece!

1 Like

This happened to me yesterday evening. A large piece of white American oak, no rhyme or reason - was not happy and I can’t get the wood again…

1 Like

Once, co-inky-dink… twice (scratches head)…

Have you tried a different file to troubleshoot if it is the g-code or if is the machine?

Can you run the circle diamond square pattern? Just a suggestion

Folks it was clearly a hardware failure on the Y axis of the “Stepoko” controller. I inverted the wires on X&Y and the crazy behavior moved to the X axis where two clicks in UGS moved the cutter completely across the entire X range. Controller is being RMA’d back to Sparkfun for a replacement (its only a few months new).

This controller runs very hot and uses the entire X aluminum extrusion as a heat sink (with a thermal pad in between). There is a big block of aluminium on the underside of the board and heat sinks on the top. I only have experience with the little Pololu-like plugin drivers which run hot but don’t need heat sinks so I have no idea why this board generates so much heat but I admit that I am a little suspicious of its reliability at this point.

The gcode was generated by Vcarve which seems to do a really good job in my rookie opinion after a few weeks of use…