Precision Collets Getting Stuck in Compact Router

I have the Carbide compact router and ordered the precision collet set from Carbide 3d. I have no issues with the 1/4 collet but the 1/8 is extremely tight. I installed it for a project and it would not come out of the router. I was able to get the bit out with a pair of pliers but the collet wouldn’t budge. After some time I was able to work the collet loose, but now I am unable to fit a bit in the collet.

Has anyone else experienced this with the 1/8 precision collet?

Please contact us about this at and we’ll get it sorted out.


@WillAdams I also have this exact problem, except for both sizes. My router came with the 1/8" & 1/4" collets, which I assume are the precision collets you also sell. The machining looked very nice, but they seem to be very soft material. Mine also got stuck.

I had assumed I overtightened them, but then I realized that they have no auto ejection mechanism like ER collets.

I’ll contact support on Monday.

Support answers e-mails on the weekends (also holidays and late evenings) as best we can.

Simply keeping things clean and not overtightening should be all that’s necessary (and never install and tighten a collet w/o the correct size endmill in place).

The collets should be spring/tool steel — while they aren’t hardened, they shouldn’t be especially soft.

Have you tried them in another router brand? Meaning do they stick in the Carbide3D Router or in a Makita brand router, or both? I’d love for someone to test my theory.

Theory: Surface finish and spindle hardness

Reason: I make 99% of my own collets…(1/8, 4mm, 6mm, 1/4, 5/16, 3/8)…(So I’d like to learn from this problem)

1 Like

Thank you for @WillAdams for the quick response and excellent customer service! :smile:

I had the same problem. I ended up buying more precision collets.

I had the same problem with the precision collets in my Makita router. I tried the plier route a couple of times but then figured out I could use a rare earth magnet attached to a piece of scrap plywood to pull the collet out. Worked much easier and without the damage the plier method seemed to cause.

Have the same issue with the Makita and 1/8 precision collet from C3D. Anyone have the issue with the Elaire 1/8 collet?

I haven’t had any issues w/ either collet sticking in either a Makita or a Carbide Compact Router.

If you have such difficulties, please let us know at and we’ll do our best to assist.

1 Like

Same here, with both the 1/4 and 1/8th. I DREAD tool changes because of this. And now I’m actually completely unable to get the collet out of the carbide router. I’ve even tried WD40 with no luck.

Quick follow-up: Liquid Wrench got the job done. Not sure if it’s because it’s better than WD40, or it was simply the result of multiple applications and a lot of soak time between the both of them.

How does the liquid wrench get along with all of the dust accumulated down there? Does it gum up the works so to speak?

I guess it could, but I just used a paper towel to wipe the inside really well, and clean off the threads.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.