Problem Homing - loud stutter

Has anyone experienced this problem while the Shapeoko is going through the homing process? It just makes this loud stutter and then it stays put there stuttering away until I turn the machine off. My machine is currently unusable. Any help or suggestions are appreciated. Thanks.

What axis? Does it do that when it gets to its limit? If so, it’s an issue with your switch. Is it making contact with the switch?

1 Like

Sounds like the homing switch circuit it not working.

Steps I would take:

Verify you can move each axis and contact the homing switch. This type of stuttering happens to me when something prevents the axis from moving to contact the switch.

Verify homing switches are connected. Move each axis far from its switch. Turn on system and manually press each homing switch as that axis starts to move, system should think it is homed. If the system does not react to your manually pressing the switch on the axis that is moving, press the other switches, it could be the homing switches are not connected properly.

Good luck.


It does appear to get to its limit and appears to be making contact with the switch .

I’ll try these suggestions tomorrow and report back . Thanks guys.

Mine did this a couple of times - pretty unpleasant noise, right?! I found that the homing switch on my X was not being fully activated. I loosened the fasteners holding it, moved it as far toward the right as I could and re-tightened whilst holding it. I manually moved the axis and checked I could hear the switch click then tried it under power. Had no issues since.

1 Like

I actually added a set screw because x-axis was too close for my liking. Then I ended up putting on Mr. Beavers proximity switches which is a far better option.

1 Like

Loud noises can be caused by a couple of things:

  • lack of electrical continuity — check wiring and connectors

If they happen at the end of travel after normal movement then it’s the homing switches — we have a page on troubleshooting them here:

Possibilities are:

  • switches not plugged in properly
  • bad switch or wire
  • problem on control board
  • machine mechanically unable to hit switch to close it

Thanks all. Problem solved. It was as easy as the router power cord not allowing the switch to touch the plate. However, without your assistance I would have spent hours trying to figure it out. Love this forum.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.